Introduction

This database design includes features and attributes that satisfy the requirements for the Theatre Geospatial Database (TGD) - Urban specification.

Enterprise databases have reserved words that cannot be used to define a table or attribute. Any items that are reserved words have been aliased and are identified in italic. The actual name stored in the database is defined followed by the italic aliased name.

These include:

  • ARE_ aliased as ARE
  • LEN_ aliased as LEN
  • MIN_ aliased as MIN
  • USE_ aliased as USE


List of F_CODEs

PLTS banner

TGD - Urban

List of F_Codes

F_CODE LAYER DESCRIPTION FEATURE TYPE
AA010 ExtractA Mine AREA
AA010 ExtractL Mine LINE
AA010 ExtractP Mine POINT
AA012 ExtractA Quarry AREA
AA012 ExtractL Quarry LINE
AA012 ExtractP Quarry POINT
AA040 RigwellP Rig/Superstructure POINT
AA050 RigwellP Well POINT
AA052 ExtractA Oil/Gas Field AREA
AA052 ExtractP Oil/Gas Field POINT
AB000 DisposeA Disposal Site/Waste Pile AREA
AB010 DisposeA Wrecking Yard/Scrap Yard AREA
AC000 ProcessA Processing/Treatment Plant AREA
AC000 ProcessP Processing/Treatment Plant POINT
AC010 ProcessA Blast Furnace AREA
AC010 ProcessP Blast Furnace AREA
AC020 RigwellP Catalystic Cracker POINT
AC030 TreatA Settling Basin/Sludge Pond AREA
AC040 ProcessA Oil/Gas Facilities AREA
AD010 PowerA Power Plant AREA
AD020 PowerP Solar Panels POINT
AD030 SubstatA Substation/Transformer Yard AREA
AD030 SubstatP Substation/Transformer Yard POINT
AE010 ProcessA Assembly Plant AREA
AE010 ProcessP Assembly Plant POINT
AF010 ObstrP Chimney/Smokestack POINT
AF020 IndL Conveyor LINE
AF030 NuclearA Cooling Tower AREA
AF030 ObstrP Cooling Tower POINT
AF040 ObstrP Crane POINT
AF070 ObstrP Flare Pipe POINT
AH010 MilA Bastion AREA
AH010 MilP Bastion POINT
AH050 FortA Fortification AREA
AH050 FortP Fortification POINT
AH060 MilA Underground Bunker AREA
AH060 MilP Underground Bunker POINT
AH070 RoadP Check Point POINT
AI020 MobileA Mobile Home Park AREA
AJ030 TreatA Feedlot/Stockyard/Holding Pen AREA
AJ030 TreatP Feedlot/Stockyard/Holding Pen POINT
AJ050 ObstrP Windmill POINT
AK020 LandmrkP Amusement Park Attraction POINT
AK030 LandmrkA Amusement Park Attraction AREA
AK040 SportA Athletic Field AREA
AK060 LandmarkA Camp Ground/Campsite AREA
AK060 LandmarkP Camp Ground/Campsite POINT
AK070 LandmrkA Drive-In Theater AREA
AK090 SportA Fairgrounds AREA
AK100 SportA Golf Course AREA
AK110 SportA Grandstand AREA
AK120 LandmrkA Park AREA
AK130 SportA Race Track AREA
AK130 LandmrkL Race Track LINE
AK150 LandmrkL Ski Jump LINE
AK150 LandmrkP Ski Jump POINT
AK160 LandmrkA Stadium/Amphitheater AREA
AK170 SportA Swimming Pool AREA
AK180 LandmrkA Zoo/Safari Park AREA
AL005 BndL Animal Sanctuary Line LINE
AL012 MispopA Archaeological Site AREA
AL012 MispopP Archaeological Site POINT
AL015 BuildA Building AREA
AL015 BuildL Building LINE
AL015 BuildP Building POINT
AL017 FirehydrantP Fire Hydrant POINT
AL019 BuildA Shed AREA
AL019 BuildP Shed POINT
AL020 BuiltupA Built-Up Area AREA
AL020 BuiltupP Built-Up Area POINT
AL030 LandmrkA Cemetery AREA
AL030 LandmrkP Cemetery POINT
AL045 CmpxindA Complex Outline Area ARES
AL060 TeethA Dragon Teeth AREA
AL060 TeethL Dragon Teeth LINE
AL070 BarrierL Fence LINE
AL100 MispopP Hut POINT
AL105 MispopA Settlement AREA
AL105 MispopP Settlement POINT
AL110 LightStandardP Light Standard POINT
AL120 MilA Missile Site AREA
AL120 MilP Missile Site POINT
AL130 LandmrkP Monument POINT
AL135 MispopA Native Settlement AREA
AL135 MispopP Native Settlement POINT
AL140 NuclearA Particle Accelerator AREA
AL140 NuclearP Particle Accelerator POINT
AL170 PlazaA Plaza/City Square AREA
AL200 RuinsA Ruins AREA
AL200 RuinsP Ruins POINT
AL210 ShedL Snow/Rock Shed LINE
AL210 ShedP Snow/Rock Shed POINT
AL240 TowerP Tower (Non-Communication) POINT
AL250 MispopP Underground Dwelling POINT
AL260 BarrierL Wall LINE
AM010 StorageA Depot AREA
AM010 StorageP Depot Storage POINT
AM020 AgristrA Grain Bin/Grain Silo AREA
AM020 AgristrP Grain Bin/Grain Silo POINT
AM030 AgristrA Grain Elevator AREA
AM030 AgristrP Grain Elevator POINT
AM031 IndP Timber Yard POINT
AM060 StorageA Storage Bunker/Storage Mound AREA
AM060 StorageP Storage Bunker/Storage Mound POINT
AM070 StorageA Tank AREA
AM070 StorageP Tank POINT
AM080 StorageA Water Tower AREA
AM080 StorageP Water Tower POINT
AM999 StorageA Hazardous Materials Storage AREA
AM999 StorageP Hazardous Materials Storage POINT
AN010 RailrdL Railroad Track LINE
AN050 RailrdL Railroad Siding/Railroad Spur LINE
AN050 RailrdP Railroad Siding/Railroad Spur POINT
AN060 RryardA Railroad Yard/Marshalling Yard AREA
AN060 RryardP Railroad Yard/Marshalling Yard POINT
AN075 RryardA Railroad Turntable AREA
AN075 RailrdP Railroad Turntable POINT
AP010 TrackL Cart Track LINE
AP020 InterA Interchange AREA
AP020 InterL Interchange LINE
AP020 InterP Interchange POINT
AP030 RoadL Road LINE
AP030 TransP Route Marker POINT
AP032 RoadP Road Ramp POINT
AP040 TransL Gate LINE
AP040 RoadP Gate POINT
AP041 TransL Barrier LINE
AP041 RoadP Barrier POINT
AP050 TrailL Trail LINE
AQ010 LiftL Aerial Cable/Ski Lift LINE
AQ040 BridgeA Bridge/Overpass/Viaduct AREA
AQ040 BridgeL Bridge/Overpass/Viaduct LINE
AQ040 BridgeP Bridge/Overpass/Viaduct POINT
AQ045 BridgeP Bridge Span POINT
AQ050 TransP Bridge Superstructure POINT
AQ058 RoadP Constriction Expansion POINT
AQ060 MisaeroP Control Tower POINT
AQ064 CausewayL AQ064 LINE
AQ065 MiscA Culvert AREA
AQ065 MiscL Culvert LINE
AQ065 CulvertP Culvert POINT
AQ068 RoadP Drop Gate POINT
AQ070 FerryL Ferry Crossing LINE
AQ070 FerryP Ferry Crossing POINT
AQ110 MisaeroP Mooring Mast POINT
AQ111 BridgeL Prepared Raft/Float Bridge LINE
AQ111 BridgeP Prepared Raft/Float Bridge POINT
AQ113 PipeL Pipeline/Pipe LINE
AQ115 ManholeP Manhole Cover POINT
AQ116 PumpingA Pumping Station AREA
AQ116 PumpingP Pumping Station POINT
AQ118 RoadP Sharp Curve POINT
AQ119 TransP Route Marker POINT
AQ125 StationA Station AREA
AQ125 StationP Station POINT
AQ130 TunnelA Tunnel AREA
AQ130 TunnelL Tunnel LINE
AQ130 TunnelP Tunnel POINT
AQ135 RestA Vehicle Stopping Area/Rest Area AREA
AQ135 RestP Vehicle Stopping Area/Rest Area POINT
AQ140 VehiclestorageA Vehicle Storage Area/Parking Area AREA
AQ160 TrafficLightP Traffic Light POINT
AT005 HazardL Cable LINE
AT010 CommP Disk/Dish POINT
AT020 MilA Early Warning Radar Site AREA
AT020 MilP Early Warning Radar Site POINT
AT030 PowerL Power Transmission Line LINE
ATO40 UtilP Power Transmission Pylon POINT
AT045 MilA Radar Transmitter AREA
AT045 MilP Radar Transmitter POINT
AT050 CommA Communication Building AREA
ATO50 CommP Communication Building POINT
AT060 TeleL Telephone/Telegraph Line LINE
AT070 UtilP Telephone/Telegraph Pylon POINT
AT080 CommP Communication Tower POINT
BA010 CoastL Coastline/Shoreline LINE
BA020 CoastA Foreshore AREA
BA030 CoastA Island AREA
BA040 CoastA Water AREA
BA050 CoastA Beach AREA
BB010 HarborP Anchorage POINT
BB019 HarborP Anchor POINT
BB020 BerthP Berth POINT
BB040 SeastrtA Breakwater/Groyne AREA
BB040 SeastrtL Breakwater/Groyne LINE
BB090 HarborA Drydock AREA
BB140 SeastrtA Jetty AREA
BB140 SeastrtL Jetty LINE
BB150 LandingA Landing Place AREA
BB150 LandingP Landing Place POINT
BB170 LoadingA Offshore Loading Facility AREA
BB170 LoadingP Offshore Loading Facility POINT
BB190 PierA Pier/Wharf/Quay AREA
BB190 PierL Pier/Wharf/Quay LINE
BB220 RampP Ramp (Maritime) POINT
BB230 SeastrtL Seawall LINE
BB240 RampA Slipway/Patent Slip AREA
BB240 RampL Slipway/Patent Slip LINE
BC010 BuoybcnP Beacon POINT
BC020 BuoybcnP Buoy POINT
BC040 LightsP Light POINT
BC050 LighthouseA Lighthouse AREA
BC050 LighthouseP Lighthouse POINT
BC070 BuoybcnP Light Vessel/Lightship AREA
BD000 HazardA Underwater Danger/Hazard AREA
BD000 HazardP Underwater Danger/Hazard POINT
BD001 MineP Mine Naval Point POINT
BD010 HydObstrucA Breakers AREA
BD010 HazardL Breakers LINE
BD010 HydObstrucP Breakers POINT
BD020 HazardA Crib AREA
BD020 HazardP Crib POINT
BD040 HydObstrucA Eddies AREA
BD040 HydObstrucP Eddies POINT
BD050 DangerA Foul Ground AREA
BD070 HydObstrucP Unknown Obstruction POINT
BD100 DangerA Pile/Piling/Post AREA
BD100 DangerP Pile/Piling/Post POINT
BD110 LoadingP Platform POINT
BD120 DangerA Reef AREA
BD120 DangerL Reef LINE
BD130 DangerP Rock POINT
BD140 HydroA Snags/Stumps AREA
BD180 HazardA Wreck AREA
BD180 DangerP Wreck Point
BE010 ElevA Depth Curve AREA
BE015 DepthL Depth Contour LINE
BE019 ElevA Depth Area AREA
BE020 SoundP Sounding POINT
BE050 ElevA Beach Profile AREA
BF010 BotcharP Bottom Characteristics POINT
BG010 HydroP Current Arrow POINT
BH010 AquedctA Aqueduct AREA
BH010 AquedctL Aqueduct LINE
BH010 AquedctP Aqueduct POINT
BH015 SwampA Bog AREA
BH020 WatrcrsA Canal AREA
BH020 WatrcrsL Canal LINE
BH030 WatrcrsA Ditch AREA
BH030 WatrcrsL Ditch LINE
BH040 TreatA Filtration/Aeration Beds AREA
BH050 TreatA Fish Hatchery/Fish Farm/Marine Farm AREA
BH060 IndL Flume LINE
BH070 FordL Ford LINE
BH070 FordP Ford POINT
BH075 SpringP Fountain POINT
BH077 GrassA Hummock POINT/LINE/AREA
BH080 LakeresA Lake/Pond AREA
BH090 InundA Land Subject to Inundation AREA
BH095 SwampA Marsh/Swamp AREA
BH100 MiscL Moat LINE
BH110 MiscL Penstock LINE
BH120 RapidsL Rapids LINE
BH120 RapidsP Rapids POINT
BH130 LakeresA Reservoir AREA
BH135 CropA Rice Field AREA
BH140 WatrcrsA River/Stream AREA
BH140 WatrcrsL River/Stream LINE
BH145 RapidsP River/Stream Vanishing Point POINT
BH150 Lndfrm1A Salt Pan AREA
BH155 ExtractA Salt Evaporator AREA
BH160 Lndfrm1A Sebkha AREA
BH165 DamA Spillway AREA
BH165 DamL Spillway LINE
BH165 DamP Spillway POINT
BH170 SpringP Spring/Water Hole POINT
BH180 RapidsL Waterfall LINE
BH180 RapidsP Waterfall POINT
BH210 HydroL Inland Shoreline LINE
BI010 CisternP Cistern POINT
BI020 DamA Dam/Wier AREA
BI020 DamL Dams/Weir LINE
BI020 DamP Dam/Weir POINT
BI030 LockA Lock AREA
BI030 LockL Lock LINE
BI030 LockP Lock POINT
BI040 MiscL Sluice Gate LINE
BI040 MiscP Sluice Gate POINT
BI050 MiscA Water Intake Tower AREA
BI050 MiscP Water Intake Tower POINT
BJ020 Lndfrm2A Moraine AREA
BJ030 LandIceA Glacier AREA
BJ065 SeaiceA Ice Shelf AREA
BJ070 SeaiceA Pack Ice AREA
BJ080 SeaiceA Polar Ice AREA
BJ100 LandIceA Snow/Ice Field AREA
BJ110 TundraA Tundra AREA
CA010 ContourL Contour (Land) LINE
CA030 ElevP Spot Elevation Point POINT
DA010 GroundA Ground Surface Element AREA
DA020 VegA Barren Ground AREA
DB010 BluffL Bluff/Cliff/Escarpment LINE
DB030 Lndfrm1A Cave AREA
DB030 MtnP Cave POINT
DB060 Lndfrm2A Crevice/Crevasse AREA
DB060 LandfrmL Crevice/Crevasse LINE
DB070 EmbankL Cut LINE
DB080 DepressA Depression AREA
DB090 EmbankA Embankment/Fill AREA
DB090 EmbankL Embankment/Fill LINE
DB110 LandfrmL Fault LINE
DB115 ThermalP Geothermal Feature POINT
DB160 Lndfrm2A Rock Strata/Rock Formation AREA
DB170 Lndfrm1A Sand Dunes/Sand Hills AREA
DB180 PhysA Volcano AREA
DB180 ThermalP Volcano POINT
DB200 Lndfrm1A Gully/Gorge AREA
EA010 CropA Cropland AREA
EA020 HedgeL Hedgerow LINE
EA030 OrchardA Nursery AREA
EA040 OrchardA Orchard/Plantation AREA
EA050 OrchardA Vineyard AREA
EA055 VegA Hops AREA
EB010 GrassA Grassland AREA
EB020 GrassA Scrub/Brush AREA
EC010 GrassA Bamboo/Cane AREA
EC020 OasisA Oasis AREA
EC020 OasisP Oasis POINT
EC030 TreesA Trees AREA
EC030 TreesL Tree Rows LINE
EC030 TreesP Trees POINT
EC040 FirebrkA Cleared Way/Cut Line/Firebreak AREA
EC040 FirebrkL Cleared Way/Firebreak LINE
FA000 PolbndL Administrative Boundary LINE
FA001 PolbndA Administrative Area AREA
FA001 PolbndP Administrative Point POINT
FA015 MilA Firing Range AREA
FA015 MilP Firing/Gunnery Range POINT
FA020 PolbndL Armistice Line LINE
FA030 PolbndL Cease Fire Line LINE
FA050 PolbndL Mandate Line/Convention Line LINE
FA060 PolbndL De Facto Boundary LINE
FA070 PolbndA Demilitarized Zone AREA
FA090 IndL Geophysical Prospect Grid LINE
FA110 PolbndL International Date Line LINE
FA170 PolbndA Zone of Occupation AREA
FC031 PolbndA Maritime AREA
GA005 AirspaceA Airspace AREA
GA015 AirspaceA Special Use Airspace AREA
GA035 NavaidsP Navaids POINT
GA045 RouteA Route AREA
GA045 RouteL Route LINE
GA047 RouteL Complex Term Route LINE
GA048 NavaidsP ILS Component POINT
GA055 NavaidsP Waypoint POINT
GB005 AerofacA Airport/Airfield AREA
GB005 AerofacP Airport/Airfield POINT
GB010 MisaeroP Airport Lighting POINT
GB015 RunwayA Apron/Hardstand AREA
GB030 AerofacA Helicoptor Landing Pad AREA
GB030 AerofacP Helicoptor Landing Pad POINT
GB035 AerofacA Heliport AREA
GB035 AerofacP Heliport POINT
GB045 RunwayA Overrun/Stopway AREA
GB045 RunwayL Overrun/Stopway LINE
GB047 AerofacP Airport RP Coordinate POINT
GB050 AerofacA Revetment AREA
GB050 RevetmentL Revetment Line LINE
GB054 RunwayP Runway Graduated Point POINT
GB055 RunwayA Runway AREA
GB055 RunwayL Runway LINE
GB055 RunwayP Runway POINT
GB056 RunwayP Runway End Point POINT
GB061 RunwayP Runway High Point POINT
GB062 RunwayP Runway Low Point POINT
GB075 RunwayA Taxiway AREA
GB075 RunwayL Taxiway LINE
GB220 MisaeroP Air Obstruction POINT
IA040 ParcelA Land Parcel AREA
SA050 SlopeA Slope AREA
SU001 MilA Military Base AREA
SU001 MilP Military Base POINT
SU002 RailrdL Subway LINE
SU884 MilP Training Site POINT
SU885 MilP Refueling Site POINT
SU886 MilP Farp Site POINT
SU887 MilP Ammo Point POINT
SU888 MilP Observation Point POINT
SU992 MilA Restricted Area AREA
SU993 MilA Cantonment Area AREA
SU994 MilA Landing Zone AREA
SU995 MilA Drop Zone AREA
SU997 MilA Maneuver AREA
SU998 MilA Training Area AREA
SU999 MilA Installation Boundary AREA
ZB020 MarkersP Bench Mark POINT
ZB035 MarkersP Control Point POINT
ZC040 MagareaA Magnetic Disturbance Area AREA
ZD012 GeoinfoP Geographic Information POINT
ZD019 PopP General Miscellaneous Feature POINT
ZD020 VoidA Void Collection Area AREA
ZD045 TextP Text Description POINT


Global Attributes

Global Attributes

The Urban data model contain several global attributes that are included with all the feature classes.

ACE

ACE Absolute Circular Error
  (-32768) Null

ACE_EVAL_METHOD_CD

ACE_EVAL_METHOD_CD Absolute Circular Error Evaluation Method
  ACA Geodetic Survey Control - adequate sample
  ACS Geodetic Survey Control - small sample
  AHA Photogrammetric (old stats, unable to convert to ANA due to significant bias)
  ANA Photogrammetric Control (GDASII) - adequate sample
  ANS Photogrammetric Control (GDASII) - small sample
  APA Photogrammetric Control (IEC, FPE, NPF) - adequate sample
  APS Photogrammetric Control (IEC, FPE, NPF) - small sample
  AXB Extrapolation
  AZD Unable to perform metric evaluation, other than EZM, EZG, AZF, and AZE (assumed adequate)
  AZE Insufficient control presently available to perform metric evaluation (assumed adequate)
  AZF Insufficient identifiable map features for metric evaluation (assumed adequate)
  BMD Error Budget Evaluation (Production Data)
  CLD Accuracy evaluation printed on the sheet or evaluation derived from source accuracy
  CXB Results from a large sampling of post-production evaluations that are similar in compilation or specification
  EMC Product specification accuracy value (assumed adequate)
  EYC Very old evaluation of unknown origin
  EZD Estimate based on analyst familiarity
  EZG Insufficient graticule for metric evaluation (assumed limited)
  EZM Scale too small (<1:300,000) to perform metric evaluation on GDAS systems (assumed adequate)
  EZZ Digital Product, no evaluation method available
  (FZD) Evaluation deferred (no measurement)

ALE

ALE Absolute Linear Error
  (-32768) Null

ALE_EVAL_METHOD_CD

ALE_EVAL_METHOD_CD Absolute Linear Error Evaluation Method
  ACA Geodetic Survey Control - adequate sample
  ACS Geodetic Survey Control - small sample
  AHA Photogrammetric (old stats, unable to convert to ANA due to significant bias)
  ANA Photogrammetric Control (GDASII) - adequate sample
  ANS Photogrammetric Control (GDASII) - small sample
  APA Photogrammetric Control (IEC, FPE, NPF) - adequate sample
  APS Photogrammetric Control (IEC, FPE, NPF) - small sample
  AXB Extrapolation
  AZD Unable to perform metric evaluation, other than EZM, EZG, AZF, and AZE (assumed adequate)
  AZE Insufficient control presently available to perform metric evaluation (assumed adequate)
  AZF Insufficient identifiable map features for metric evaluation (assumed adequate)
  BMD Error Budget Evaluation (Production Data)
  CLD Accuracy evaluation printed on the sheet or evaluation derived from source accuracy
  CXB Results from a large sampling of post-production evaluations that are similar in compilation or specification
  EMC Product specification accuracy value (assumed adequate)
  EYC Very old evaluation of unknown origin
  EZD Estimate based on analyst familiarity
  EZG Insufficient graticule for metric evaluation (assumed limited)
  EZM Scale too small (<1:300,000) to perform metric evaluation on GDAS systems (assumed adequate)
  EZZ Digital Product, no evaluation method available
  (FZD) Evaluation deferred (no measurement)

COMM_CPYRT_NOTICE

COMM_CPYRT_NOTICE Commercial Copyright Notice
  (N/A) Null

COMM_LIC_TIER_NOTICE

COMM_LIC_TIER_NOTICE Distribution of Commercial Data
  (N/A) Null

COMMENTS

COMMENTS Comments
  No default value

COUNTRY_CODE

COUNTRY_CODE Country Code
  AF AFGHANISTAN
  AL ALBANIA
  AG ALGERIA
  AQ AMERICAN SAMOA
  AN ANDORRA
  AO ANGOLA
  AY ANTARCTICA
  AC ANTIGUA AND BARBUDA
  AR ARGENTINA
  AM ARMENIA
  AS AUSTRALIA
  AU AUSTRIA
  AJ AZERBAIJAN
  BF THE BAHAMAS
  BA BAHRAIN
  FQ BAKER ISLAND
  BG BANGLADESH
  BB BARBADOS
  BO BELARUS
  BE BELGIUM
  BH BELIZE
  BN BENIN
  BT BHUTAN
  BL BOLIVIA
  BK BOSNIA AND HERZEGOVINA
  BC BOTSWANA
  BR BRAZIL
  IO BRITISH INDIAN OCEAN TERRITORY
  BX BRUNEI
  BU BULGARIA
  UV BURKINA FASO
  BM BURMA
  BY BURUNDI
  CB CAMBODIA
  CM CAMEROON
  CA CANADA
  CV CAPE VERDE
  CJ CAYMAN ISLANDS
  CT CENTRAL AFRICAN REPUBLIC
  CD CHAD
  CI CHILE
  CH CHINA
  KT TERRITORY OF CHRISTMAS ISLAND
  IP CLIPPERTON ISLAND
  CK COCOS ISLANDS
  CO COLOMBIA
  CQ COMMONWEALTH OF THE NORTHERN MARIANA ISLANDS
  CN COMOROS
  CF CONGO (Brazzaville)
  CG CONGO (Kinshasa)
  CW COOK ISLANDS
  CR CORAL SEA ISLANDS TERRITORY
  CS COSTA RICA
  IV C?TE D�IVOIRE
  HR CROATIA
  CU CUBA
  CY CYPRUS
  EZ CZECH REPUBLIC
  DA DENMARK
  DJ DJIBOUTI
  DO DOMINICA
  DR DOMINICAN REPUBLIC
  TT EAST TIMOR
  EC ECUADOR
  EG EGYPT
  ES EL SALVADOR
  EK EQUATORIAL GUINEA
  ER ERITREA
  EN ESTONIA
  ET ETHIOPIA
  EU EUROPA ISLAND
  FJ FIJI
  FI FINLAND
  FR FRANCE
  FS FRENCH SOUTHERN AND ANTARCTIC LANDS
  FP TERRITORY OF FRENCH POLYNESIA
  GB GABON
  GA THE GAMBIA
  GG GEORGIA
  GM GERMANY
  GH GHANA
  GR GREECE
  GJ GRENADA
  GQ GUAM
  GT GUATEMALA
  GV GUINEA
  PU GUINEA-BISSAU
  GY GUYANA
  HA HAITI
  HM HEARD ISLAND AND MCDONALD ISLANDS
  HO HONDURAS
  HK HONG KONG SPECIAL ADMINISTRATIVE REGION
  HQ HOWLAND ISLAND
  HU HUNGARY
  IC ICELAND
  IN INDIA
  ID INDONESIA
  IR IRAN
  IZ IRAQ
  EI IRELAND
  IS ISRAEL
  IT ITALY
  JM JAMAICA
  JA JAPAN
  DQ JARVIS ISLAND
  JQ JOHNSTON ATOLL
  JO JORDAN
  JU JUAN DE NOVA ISLAND
  KZ KAZAKHSTAN
  KE KENYA
  KQ KINGMAN REEF
  KR KIRIBATI
  KN NORTH KOREA
  KS SOUTH KOREA
  KU KUWAIT
  KG KYRGYZSTAN
  LA LAOS
  LG LATVIA
  LE LEBANON
  LT LESOTHO
  LI LIBERIA
  LY LIBYA
  LS LIECHTENSTEIN
  LH LITHUANIA
  LU LUXEMBOURG
  MC MACAU SPECIAL ADMINISTRATIVE REGION
  MK THE FORMER YUGOSLAV REPUBLIC OF MACEDONIA
  MA MADAGASCAR
  MI MALAWI
  MY MALAYSIA
  MV MALDIVES
  ML MALI
  MT MALTA
  RM MARSHALL ISLANDS
  MR MAURITANIA
  MP MAURITIUS
  MX MEXICO
  FM FEDERATED STATES OF MICRONESIA
  MQ MIDWAY ISLANDS
  MD MOLDOVA
  MN MONACO
  MG MONGOLIA
  MO MOROCCO
  MZ MOZAMBIQUE
  WA NAMIBIA
  NR NAURU
  BQ NAVASSA ISLAND
  NP NEPAL
  NL NETHERLANDS
  NZ NEW ZEALAND
  NU NICARAGUA
  NG NIGER
  NI NIGERIA
  NE NIUE
  NF NORFOLK ISLAND
  NO NORWAY
  MU OMAN
  PP PAPUA NEW GUINEA
  PK PAKISTAN
  PS PALAU
  LQ PALMYRA ATOLL
  PM PANAMA
  PF PARACEL ISLANDS
  PA PARAGUAY
  PE PERU
  RP PHILIPPINES
  PL POLAND
  PO PORTUGAL
  QA QATAR
  RO ROMANIA
  RS RUSSIA
  RW RWANDA
  SC SAINT KITTS AND NEVIS
  ST SAINT LUCIA
  VC SAINT VINCENT AND THE GRENADINES
  WS SAMOA
  SM SAN MARINO
  TP SAO TOME AND PRINCIPE
  SA SAUDI ARABIA
  SG SENEGAL
  YI SERBIA AND MONTENEGRO
  SE SEYCHELLES
  SL SIERRA LEONE
  SN SINGAPORE
  LO SLOVAKIA
  SI SLOVENIA
  BP SOLOMON ISLANDS
  SO SOMALIA
  SF SOUTH AFRICA
  SP SPAIN
  PG SPRATLY ISLANDS
  CE SRI LANKA
  SU SUDAN
  NS SURINAME
  WZ SWAZILAND
  SW SWEDEN
  SZ SWITZERLAND
  SY SYRIA
  TI TAJIKISTAN
  TZ TANZANIA
  TH THAILAND
  TO TOGO
  TN TONGA
  TD TRINIDAD AND TOBAGO
  TS TUNISIA
  TU TURKEY
  TX TURKMENISTAN
  TV TUVALU
  UG UGANDA
  UP UKRAINE
  AE UNITED ARAB EMIRATES
  UK UNITED KINGDOM
  US UNITED STATES
  UY URUGUAY
  UZ UZBEKISTAN
  NH VANUATU
  VT VATICAN CITY
  VE VENEZUELA
  VM VIETNAM
  WQ WAKE ATOLL
  YM YEMEN
  ZA ZAMBIA
  ZI ZIMBABWE
  TW TAIWAN
  UNK UNKNOWN

CREATION_DATE

CREATION_DATE Creation Date
  No default value

ORIG_SOURCE_INFO

ORIG_SOURCE_INFO Original Source Information
  No default value

ORIG_SOURCE_DATE

ORIG_SOURCE_DATE Original Source Date
  No default value

ORIGINATING_SOURCE

ORIGINATING_SOURCE Originating Source
  Multiple Multiple
  Other Other
  Unknown Unknown
  Arc Digitized Raster Graphic (ADRG) Arc Digitized Raster Graphic (ADRG)
  Automated Aeronautical Facilities Information File (AAFIF) Automated Aeronautical Facilities Information File (AAFIF)
  Boundaries (International Boundaries Database) Boundaries (International Boundaries Database)
  Brigade Database Brigade Database
  City Graphic City Graphic
  Combat Chart Combat Chart
  Compressed Arc Digitized Raster Graphic (CADRG) Compressed Arc Digitized Raster Graphic (CADRG)
  Controlled Imagery Base 1 (CIB1) Controlled Imagery Base 1 (CIB1)
  Controlled Imagery Base 5 (CIB5) Controlled Imagery Base 5 (CIB5)
  Digital Nautical Chart (DNC) Digital Nautical Chart (DNC)
  Digital Print File (DPF) Digital Print File (DPF)
  Digital Terrain Elevation Data 1 (DTED1) Digital Terrain Elevation Data 1 (DTED1)
  Digital Terrain Elevation Data 2 (DTED2) Digital Terrain Elevation Data 2 (DTED2)
  Digital Terrain Elevation Data 3 (DTED3) Digital Terrain Elevation Data 3 (DTED3)
  Digital Terrain Elevation Data 4 (DTED4) Digital Terrain Elevation Data 4 (DTED4)
  Digital Vertical Obstruction File (DVOF) Digital Vertical Obstruction File (DVOF)
  Foundation Feature Data (FFD) Foundation Feature Data (FFD)
  Foundation Feature Data/Relocatable Target Data (FFD/RTAD) Foundation Feature Data/Relocatable Target Data (FFD/RTAD)
  GEOBASE GEOBASE
  GEOREACH GEOREACH
  GeoCover/LandCover GeoCover/LandCover
  Geonames Geonames
  Image City Map (ICM) Image City Map (ICM)
  Imagery (IKONOS) Imagery (IKONOS)
  Imagery (NTM) Imagery (NTM)
  Imagery (OrbView3) Imagery (OrbView3)
  Imagery (OrbView5) Imagery (OrbView5)
  Imagery (Quickbird) Imagery (Quickbird)
  Imagery (World View) Imagery (World View)
  Imagery (Other) Imagery (Other)
  Interim Terrain Data (ITD) Interim Terrain Data (ITD)
  Joint Operational Graphic (JOG) Joint Operational Graphic (JOG)
  Landsat Landsat
  Littoral Warfare Data (LWD) Littoral Warfare Data (LWD)
  Mapping Charting and Geodetic (MC&G) Mapping Charting and Geodetic (MC&G)
  Mission Specific Data 1 (MSD1) Mission Specific Data 1 (MSD1)
  Mission Specific Data 2 (MSD2) Mission Specific Data 2 (MSD2)
  Mission Specific Data 3 (MSD3) Mission Specific Data 3 (MSD3)
  Mission Specific Data 4 (MSD4) Mission Specific Data 4 (MSD4)
  Mission Specific Data 5 (MSD5) Mission Specific Data 5 (MSD5)
  Modernized Integrated Data Base (MIDB) Modernized Integrated Data Base (MIDB)
  NAVTEQ Digital Data NAVTEQ Digital Data
  Native Data Source Native Data Source
  Native Map Source Native Map Source
  NIMA GIS Medical Facilities Database NIMA GIS Medical Facilities Database
  Nominally Attributed Topographic Evaluation Map (NATE Map) Nominally Attributed Topographic Evaluation Map (NATE Map)
  Planning Graphic Planning Graphic
  Reference Map Reference Map
  Raster Map - 1: 250K Raster Map - 1: 250K
  Raster Map - 1: 100K Raster Map - 1: 100K
  Raster Map - 1: 50K Raster Map - 1: 50K
  Raster Map - 1: 25K Raster Map - 1: 25K
  Raster Map - City Graphics Raster Map - City Graphics
  Shuttle Radar Topographic Mission (SRTM) Shuttle Radar Topographic Mission (SRTM)
  Site Map/Nuclear Facility Site Map/Nuclear Facility
  Tactical Oceanographic Data Lv 0 (TOD0) Tactical Oceanographic Data Lv 0 (TOD0)
  Tactical Oceanographic Data Lv 1 (TOD1) Tactical Oceanographic Data Lv 1 (TOD1)
  Tactical Oceanographic Data Lv 2 (TOD2) Tactical Oceanographic Data Lv 2 (TOD2)
  Tactical Oceanographic Data Lv 4 (TOD4) Tactical Oceanographic Data Lv 4 (TOD4)Tactical Oceanographic Data Lv 4 (TOD4)
  Tactical Oceanographic Data Lv 5 (TOD5) Tactical Oceanographic Data Lv 5 (TOD5)
  Topographic Line Map (TLM) Topographic Line Map (TLM)
  United Nations Data United Nations Data
  Urban Tactical Planner (UTP) Urban Tactical Planner (UTP)
  Urban Vector Map (UVMap) Urban Vector Map (UVMap)
  United States Geological Survey Digital Line Graph USGS DLG
  Vector Interim Terrain Data (VITD) Vector Interim Terrain Data (VITD)
  Vector Map Lv0 (VMap0) Vector Map Lv0 (VMap0)
  Vector Map Lv1 (VMap1) Vector Map Lv1 (VMap1)
  Vector Map Lv2 (VMap2) Vector Map Lv2 (VMap2
  World Vector Shoreline Plus (WVSPlus) World Vector Shoreline Plus (WVSPlus)

ORIGINATOR

ORIGINATOR Data Supplier
  No default value

PROJECT_ID

PROJECT_ID Project Identifier
  No default value

RSTRN_RELEASABILITY

RSTRN_RELEASABILITY Restriction Releasability
  No default value

SCALE

SCALE Scale
  No default value

SEC_CLASS

SEC_CLASS Security Classification
  TS Top Secret
  S Secret
  C Confidential
  U Unclassified
  1 COSMIC Top Secret-Bohemia
  2 COSMIC Top Secret-Balk
  3 NATO Secret
  4 NATO Secret-Savate
  5 NATO Secret-Avicula
  6 NATO Confidential
  7 NATO Restricted
  8 NATO Unclassified
  9 COSMIC Top Secret Atom
  10 Secret Atomal
  11 Confidential Atomal

SPEC_ID

SPEC_ID Specification Identifier
  1AA-TPC 1AA-TPC
  1AB-ONC 1AB-ONC
  1AE-JOG-A/G 1AE-JOG-A/G
  1CD-DTED-1 1CD-DTED-1
  1CE-DFAD-1 1CE-DFAD-1
  1CF-DTED-2 1CF-DTED-2
  1CG-DFAD-2 1CG-DFAD-2
  2AA/001-HAC-1 2AA/001-HAC-1
  2AA/002-HAC-2 2AA/002-HAC-2
  2AA/003-HAC-3 2AA/003-HAC-3
  2AA/004-HAC-4 2AA/004-HAC-4
  2AA/005-HAC-5 2AA/005-HAC-5
  2AA/006-HAC-6 2AA/006-HAC-6
  2AA/007-HAC-7 2AA/007-HAC-7
  2AA/008-HAC-8 2AA/008-HAC-8
  2AA/009-HAC-32768 2AA/009-HAC-9
  2AD-Combat 2AD-Combat
  3AA-TLM50 3AA-TLM50
  3AG-TLM100 3AG-TLM100
  3KA-VITD 3KA-VITD
  3KC/001-DTOP 3KC/001-DTOP
  3KH-VMAP-2 3KH-VMAP-2
  3KL-VMAP-0 3KL-VMAP-0
  3KM-VMAP-1 3KM-VMAP-1
  3KU-UVMAP 3KU-UVMAP
  4AA-ATC 4AA-ATC
  4AC-JOG-R 4AC-JOG-R
  4GE-TERCOM-L 4GE-TERCOM-L
  4GE-TERCOM-E 4GE-TERCOM-E
  4GG-TERCOM-T 4GG-TERCOM-T
  5EE-FFD 5EE-FFD
  7BC/302-BATHY 7BC/302-BATHY
  7BC/502-AERO 7BC/502-AERO
  7SC/001-MPO-1 7SC/001-MPO-1
  7SC/002-MPO-2 7SC/002-MPO-2
  7SC/005-MPO-5 7SC/005-MPO-5
  7SC/006-MPO-6 7SC/006-MPO-6
  7SC/008-MPO-8 7SC/008-MPO-8
  7SC/009-MPO-32768 7SC/009-MPO-9
  7SC/010-MPO-10 7SC/010-MPO-10
  UUU-DBCS UUU-DBCS
  DNC DNC
  Other Other
  Mission Specific Data 1 (MSD1) Mission Specific Data 1 (MSD1)
  Mission Specific Data 2 (MSD2) Mission Specific Data 2 (MSD2)
  Mission Specific Data 3 (MSD3) Mission Specific Data 3 (MSD3)
  Mission Specific Data 4 (MSD4) Mission Specific Data 4 (MSD4)
  Mission Specific Data 5 (MSD5) Mission Specific Data 5 (MSD5)

UPDATE_SOURCE_DATE

UPDATE_SOURCE_DATE Update Source Date
  No default value

UPDATE_SOURCE_INFO

UPDATE_SOURCE_INFO Update Source Information
  No default value

UPDATE_SOURCE

UPDATE_SOURCE Update Source
  Multiple Multiple
  Other Other
  Unknown Unknown
  Arc Digitized Raster Graphic (ADRG) Arc Digitized Raster Graphic (ADRG)
  Automated Aeronautical Facilities Information File (AAFIF) Automated Aeronautical Facilities Information File (AAFIF)
  Boundaries (International Boundaries Database) Boundaries (International Boundaries Database)
  Brigade Database Brigade Database
  City Graphic City Graphic
  Combat Chart Combat Chart
  Compressed Arc Digitized Raster Graphic (CADRG) Compressed Arc Digitized Raster Graphic (CADRG)
  Controlled Imagery Base 1 (CIB1) Controlled Imagery Base 1 (CIB1)
  Controlled Imagery Base 5 (CIB5) Controlled Imagery Base 5 (CIB5)
  Digital Nautical Chart (DNC) Digital Nautical Chart (DNC)
  Digital Print File (DPF) Digital Print File (DPF)
  Digital Terrain Elevation Data 1 (DTED1) Digital Terrain Elevation Data 1 (DTED1)
  Digital Terrain Elevation Data 2 (DTED2) Digital Terrain Elevation Data 2 (DTED2)
  Digital Terrain Elevation Data 3 (DTED3) Digital Terrain Elevation Data 3 (DTED3)
  Digital Terrain Elevation Data 4 (DTED4) Digital Terrain Elevation Data 4 (DTED4)
  Digital Vertical Obstruction File (DVOF) Digital Vertical Obstruction File (DVOF)
  Foundation Feature Data (FFD) Foundation Feature Data (FFD)
  Foundation Feature Data/Relocatable Target Data (FFD/RTAD) Foundation Feature Data/Relocatable Target Data (FFD/RTAD)
  GEOBASE GEOBASE
  GEOREACH GEOREACH
  GeoCover/LandCover GeoCover/LandCover
  Geonames Geonames
  Image City Map (ICM) Image City Map (ICM)
  Imagery (IKONOS) Imagery (IKONOS)
  Imagery (NTM) Imagery (NTM)
  Imagery (OrbView3) Imagery (OrbView3)
  Imagery (OrbView5) Imagery (OrbView5)
  Imagery (Quickbird) Imagery (Quickbird)
  Imagery (World View) Imagery (World View)
  Imagery (Other) Imagery (Other)
  Interim Terrain Data (ITD) Interim Terrain Data (ITD)
  Joint Operational Graphic (JOG) Joint Operational Graphic (JOG)
  Landsat Landsat
  Littoral Warfare Data (LWD) Littoral Warfare Data (LWD)
  Mapping Charting and Geodetic (MC&G) Mapping Charting and Geodetic (MC&G)
  Mission Specific Data 1 (MSD1) Mission Specific Data 1 (MSD1)
  Mission Specific Data 2 (MSD2) Mission Specific Data 2 (MSD2)
  Mission Specific Data 3 (MSD3) Mission Specific Data 3 (MSD3)
  Mission Specific Data 4 (MSD4) Mission Specific Data 4 (MSD4)
  Mission Specific Data 5 (MSD5) Mission Specific Data 5 (MSD5)
  Modernized Integrated Data Base (MIDB) Modernized Integrated Data Base (MIDB)
  NAVTEQ Digital Data NAVTEQ Digital Data
  Native Data Source Native Data Source
  Native Map Source Native Map Source
  NIMA GIS Medical Facilities Database NIMA GIS Medical Facilities Database
  Nominally Attributed Topographic Evaluation Map (NATE Map) Nominally Attributed Topographic Evaluation Map (NATE Map)
  Planning Graphic Planning Graphic
  Reference Map Reference Map
  Raster Map - 1: 250K Raster Map - 1: 250K
  Raster Map - 1: 100K Raster Map - 1: 100K
  Raster Map - 1: 50K Raster Map - 1: 50K
  Raster Map - 1: 25K Raster Map - 1: 25K
  Raster Map - City Graphics Raster Map - City Graphics
  Shuttle Radar Topographic Mission (SRTM) Shuttle Radar Topographic Mission (SRTM)
  Site Map/Nuclear Facility Site Map/Nuclear Facility
  Tactical Oceanographic Data Lv 0 (TOD0) Tactical Oceanographic Data Lv 0 (TOD0)
  Tactical Oceanographic Data Lv 1 (TOD1) Tactical Oceanographic Data Lv 1 (TOD1)
  Tactical Oceanographic Data Lv 2 (TOD2) Tactical Oceanographic Data Lv 2 (TOD2)
  Tactical Oceanographic Data Lv 4 (TOD4) Tactical Oceanographic Data Lv 4 (TOD4)Tactical Oceanographic Data Lv 4 (TOD4)
  Tactical Oceanographic Data Lv 5 (TOD5) Tactical Oceanographic Data Lv 5 (TOD5)
  Topographic Line Map (TLM) Topographic Line Map (TLM)
  United Nations Data United Nations Data
  Urban Tactical Planner (UTP) Urban Tactical Planner (UTP)
  Urban Vector Map (UVMap) Urban Vector Map (UVMap)
  United States Geological Survey Digital Line Graph USGS DLG
  Vector Interim Terrain Data (VITD) Vector Interim Terrain Data (VITD)
  Vector Map Lv0 (VMap0) Vector Map Lv0 (VMap0)
  Vector Map Lv1 (VMap1) Vector Map Lv1 (VMap1)
  Vector Map Lv2 (VMap2) Vector Map Lv2 (VMap2
  World Vector Shoreline Plus (WVSPlus) World Vector Shoreline Plus (WVSPlus)

Z_VALUE_TYPE

Z_VALUE_TYPE Z Value Type
  2D Data 2D Data
  DTED1 Derived DTED1 Derived
  DTED2 -Derived DTED2 Derived
  SRTM SRTM
  Reflective Surface Derived Reflective Surface Derived
  Stereo Derived Stereo Derived
  TIN Derived TIN Derived
  Other Other
  Unknown Unknown


MagareaA -- Magnetic Disturbance Area

MagareaA -- Magnetic Disturbance Area

ZC040 Magnetic Disturbance Area
VAV Variation Anomaly Value (degrees)
  (0) Unknown


ParcelA -- Land Parcel

ParcelA -- Land Parcel

IA040 Land Parcel
No attributes except metadata


PolbndA -- Administrative Areas

PolbndA -- Administrative Areas

FA001 -- Administrative Area

FA001 Administrative Area
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (0) Unknown
  1 Buddhist
  2 Moslem
  4 Christian (undefined)
  5 Judiasm
  6 Greek Orthodox
  8 Shinto
  999 Other
USE_/USE Usage
  (23) International
  26 Primary/1st Order
  5 State
  16 City
  33 Provincial
  1001 County
  1002 Village

FA070 -- Demilitarized Zone

FA070 Demilitarized Zone
ACC Accuracy Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null
USE_/USE Usage
  (-32768) Null

FA170 -- Zone Of Occupation

FA170 Zone Of Occupation
ACC Accuracy Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null
USE_/USE Usage
  (-32768) Null

FC031 -- Maritime Area

FC031 Maritime Area
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null
USE_/USE Usage
  (23) International
  26 Primary/1st Order
  5 State
  16 City
  33 Provincial
  1001 County
  1002 Village


VoidA -- Void Collection Area

VoidA -- Void Collection Area

ZD020 Void Collection Area
VCA Void Collection Attribute
  (0) Unknown
  2 Area Too Rough to Collect
  3 No Available Imagery
  6 No Available Map Source
  7 No Suitable Imagery


BarrierL -- Fence/Wall

BarrierL -- Fence/Wall

AL070 -- Fence

AL070 Fence
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  21 Concrete
  62 Masonry (Brick/Stone)
  77 Prestressed concrete
  83 Reinforced concrete
  107 Steel
  108 Stone
  117 Wood
PFH Predominant Feature Height
  (29999) Unknown
WID Width (meters)
  (-32768) Null

AL260 -- Wall

AL260 Wall
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  21 Concrete
  62 Masonry (Brick/Stone)
  77 Prestressed concrete
  83 Reinforced concrete
  107 Steel
  108 Stone
  117 Wood
PFH Predominant Feature Height
  (29999) Unknown
WID Width (meters)
  (-32768) Null


BndL -- Animal Sanctuary Line

BndL -- Animal Sanctuary Line

AL005 Animal Sanctuary Line
NM3 Name 3
  (N/A) Null
NM4 Name 4
  (N/A) Null
TXT Text Attribute
  (N/A) Null


CoastL -- Coastline/Shoreline

CoastL -- Coastline/Shoreline

BA010 Coastline/Shoreline
EXS Existence Category
  0 Unknown
  44 Approximate/About
  (45) Natural
  46 Man-made
SLT Shoreline Type Category
  (0) Unknown
  6 Mangrove/Nipa
  8 Marsh/Swamp
  10 Rocky
  11 Rubble
  13 Sandy
  14 Stony, Shingly
  999 Other
VDC Vertical Datum Category
  0 Unknown
  (7) Mean High Water
  9 Mean High Water Springs
  10 Mean Higher High Water
  15 Mean Sea Level
  24 Mean Higher High Water Springs
  26 Highest Normal High Water
  28 Highest High Water
  30 Indian Spring High Water
  999 Other


PolbndL -- Administrative Boundaries

PolbndL -- Administrative Boundaries

FA000 -- Administrative Boundary Line

FA000 Administrative Boundary Line
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
  5 Disputed
  6 Undisputed
BST Boundary Status Type
  0 Unknown
  (1) Definite
  2 Indefinite
  3 In Dispute
  4 No Defined Boundary
NM3 Name 3
  (UNK) Unknown
NM4 Name 4
  (UNK) Unknown
TXT Text Attribute
  (N/A) Null
USE_/USE Usage
  0 Unknown
  7 Tribal
  (23) International
  26 Primary/1st Order
  30 Secondary/2nd Order
  31 Tertiary/3rd Order
  32 Insular
  70 Reserve/Reservation
  141 Forest Preserve
  155 Prohibited Area
  5 State
  16 City
  33 Provincial
  1001 County
  1002 Village

FA020 -- Armistice Line

FA020 Armistice Line
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
BST Boundary Status Type
  (-32768) Null
NM3 Name 3
  (UNK) Unknown
NM4 Name 4
  (UNK) Unknown
TXT Text Attribute
  (N/A) Null
USE_/USE Usage
  (-32768) Null

FA030 -- Cease-Fire Line

FA030 Cease-Fire Line
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
BST Boundary Status Type
  (-32768) Null
NM3 Name 3
  (N/A) Null
NM4 Name 4
  (N/A) Null
TXT Text Attribute
  (N/A) Null
USE_/USE Usage
  (-32768) Null

FA050 -- Mandate Line/Convention Line

FA050 Mandate Line/Convention Line
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
  5 Disputed
  6 Undisputed
BST Boundary Status Type
  0 Unknown
  (1) Definite
  2 Indefinite
  3 In Dispute
  4 No Defined Boundary
NM3 Name 3
  (UNK) Unknown
NM4 Name 4
  (UNK) Unknown
TXT Text Attribute
  (UNK) Unknown
USE_/USE Usage
  (-32768) Null

FA060 -- De Facto Boundary

FA060 De Facto Boundary
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
BST Boundary Status Type
  (-32768) Null
NM3 Name 3
  (UNK) Unknown
NM4 Name 4
  (UNK) Unknown
TXT Text Attribute
  (UNK) Unknown
USE_/USE Usage
  (0) Unknown
  16 City
  23 International
  26 Primary/1st Order
  999 Other

FA110 -- International Date Line

FA110 International Date Line
ACC Accuracy Category
  (-32768) Null
BST Boundary Status Type
  (-32768) Null
NM3 Name 3
  (N/A) Null
NM4 Name 4
  (N/A) Null
TXT Text Attribute
  (N/A) Null
USE_/USE Usage
  (-32768) Null


GeoinfoP -- Geographic Information

GeoinfoP -- Geographic Information

ZD012 Geographic Information
No attributes except metadata


MarkersP -- Bench Mark/Control Poin

MarkersP -- Bench Mark/Control Point

ZB020 -- Bench Mark

ZB020 Bench Mark
CPA Control Point Attribute
  0 Unknown
  (1) Bench Mark
  5 Vertical
ZV2 Highest Z-value (meters)
  -400 MinValue
  (9999) MaxValue

ZB035 -- Control Point

ZB035 Control Point
CPA Control Point Attribute
  0 Unknown
  1 Bench Mark
  (5) Vertical
ZV2 Highest Z-value (meters)
  -400 MinValue
  (9999) MaxValue


PolbndP -- Administrative Point

PolbndP -- Administrative Point

FA001 Administrative Point
NA2 Second Name
  (UNK) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


TextP -- Text Description

TextP -- Text Description

ZD045 Text Description
TXT Text Attribute
  (UNK) Unknown


DepressA -- Depression

DepressA -- Depression

DB080 Depression
TXT Text Attribute
  (UNK) Unknown


ElevA -- Elevation Areas

ElevA -- Elevation Areas

BE010 -- Depth Curve Area

BE010 Depth Curve Area
No attributes except metadata

BE019 -- Depth Area

BE019 Depth Area
No attributes except metadata

BE050 -- Beach Profile

BE050 Beach Profile
No attributes except metadata


SlopeA -- Slope

SlopeA -- Slope

SA050 Slope
GSC Ground Slope Category
  (0) Unknown
  1 0 to >45% Naturally or culturally dissected land
  2 0 to <=3% slope range
  3 >3% to <=10% slope range
  4 >10% to <=20% slope range
  5 >20% to <=30% slope range
  6 >30% to <=45% slope range
  7 >45% slope


ContourL -- Contour (Land)

ContourL -- Contour (Land)

CA010 Contour (Land)
HQC Hypsography Portrayal Category
  0 Unknown
  1 Index
  (2) Intermediate
  3 Supplementary (1/2)
  4 Form Lines
  5 Depression Index
  6 Depression Intermediate
  7 Approximate Index
  12 Intermediate Approximate
MCC Material Composition Category
  0 Unknown
  (30) Earthen
  103 Snow/Ice
ZV2 Highest Z-value (meters)
  -400 MinValue
  (9999) MaxValue


DepthL -- Depth Contour

DepthL -- Depth Contour

BE015 Depth Contour
CRV Depth Curve or Contour Value
  (0) Unknown


ElevP -- Spot Elevation Point

ElevP -- Spot Elevation Point

CA030 Spot Elevation Point
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
ELA Elevation Accuracy
  0 Unknown
  (1) Accurate
  2 Approximate
ZV2 Highest Z-value (meters)
  -400 Min Value
  (9999) Max Value


AquedctA -- Aqueduct

AquedctA -- Aqueduct

BH010 Aqueduct
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
LOC Location Category
  0 Unknown
  (4) Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


CoastA -- Coastal Areas

CoastA -- Coastal Areas

BA020 -- Foreshore

BA020 Foreshore
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BA030 -- Island

BA030 Island
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BA040 -- Water

BA040 Water (Except Inland)
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BA050 -- Beach

BA050 Beach
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


DamA -- Spillway/Dam/Weir

DamA -- Spillway/Dam/Weir

BH165 -- Spillway

BH165 Spillway
MCC Material Composition Category
  (0) Unknown
  20 Composition
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null

BI020 -- Dam/Weir

BI020 Dam/Weir
MCC Material Composition Category
  (0) Unknown
  20 Composition
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  6 Streets
  35 No Transportation Use


DangerA -- Danger Areas

DangerA -- Danger Areas

BD050 -- Foul Ground

BD050 Foul Ground
COD Certainty of Delineation
  (0) Unknown
  1 Limits and Info Known
  2 Limits and Info Unknown
MCC Material Composition Category
  (0) Unknown
  24 Coral
  84 Rock/Rocky
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
  8 Covers and Uncovers

BD100 -- Pile/Piling/Post

BD100 Pile/Piling/Post
COD Certainty of Delineation
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
  8 Covers and Uncovers

BD120 -- Reef

BD120 Reef
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Info Known
  2 Limits and Info Unknown
MCC Material Composition Category
  (0) Unknown
  24 Coral
  84 Rock/Rocky
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
  8 Covers and Uncovers


FortA -- Fortification

FortA -- Fortification

AH050 Fortification
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other


HarborA -- Drydock

HarborA -- Drydock

BB090 Drydock
LOC Location Category
  (0) Unknown
  15 On Water Surface/Floating
  30 Non-Floating
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public


HazardA -- Hazardous Areas

HazardA -- Hazardous Areas

BD000 -- Underwater Danger/Hazard

BD000 Underwater Danger/Hazard
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
COD Certainty of Delineation
  (-32768) Null
EXS Existence Category
  6 Abandoned/Disused
  (28) Operational
HDI Hydrographic Depth/Height Information
  9 Depth Known by Other Than Wire Drag
  10 Depth Known by Wire Drag
  (12) Depth Unknown
  15 Not Applicable
HDP Hydrographic Depth
  (0) Unknown
LOC Location Category
  (-32768) Null
SFC Sea Floor Feature Category
  (0) Unknown (Obstruction)
  3 Fish Haven
  999 Other
SOH Severity of Hazard
  (1) Dangerous
  2 Non-Dangerous
TXT Text Attribute
  (None) None
VAL Value
  (0) MinValue
  32767 MaxValue
VRR Vertical Reference Category
  (-32768) Null

BD020 -- Crib

BD020 Crib
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
COD Certainty of Delineation
  (-32768) Null
EXS Existence Category
  6 Abandoned/Disused
  (28) Operational
HDI Hydrographic Depth/Height Information
  9 Depth Known by Other Than Wire Drag
  10 Depth Known by Wire Drag
  (12) Depth Unknown
  15 Not Applicable
HDP Hydrographic Depth
  (0) Unknown
LOC Location Category
  (-32768) Null
SFC Sea Floor Feature Category
  (-32768) Null
SOH Severity of Hazard
  (-32768) Null
TXT Text Attribute
  (N/A) Null
VAL Value
  (0) MinValue
  32767 MaxValue
VRR Vertical Reference Category
  1 Above Surface/Does Not Cover (At High Water)
  (4) Below Surface/Submerged
  8 Covers and Uncovers

BD180 -- Wreck

BD180 Wreck
ACC Accuracy Category
  (-32768) Null
COD Certainty of Delineation
  (2) Limits and Info Unknown
EXS Existence Category
  (-32768) Null
HDI Hydrographic Depth/Height Information
  9 Depth Known by Other Than Wire Drag
  10 Depth Known by Wire Drag
  (12) Depth Unknown
  15 Not Applicable
HDP Hydrographic Depth
  (0) Unknown
LOC Location Category
  (4) Below Water Surface
  13 Hull Showing
  14 Mast Showing
  20 Funnel Showing
  21 Superstructure Showing
  28 Mast and Funnel Showing
SFC Sea Floor Feature Category
  (-32768) Null
SOH Severity of Hazard
  (1) Dangerous
  2 Non-Dangerous
TXT Text Attribute
  (N/A) Null
VAL Value
  (-32768) Null
VRR Vertical Reference Category
  1 Above Surface/Does Not Cover (At High Water)
  (4) Below Surface/Submerged
  8 Covers and Uncovers


HydObstrucA -- Breakers/Eddies

HydObstrucA -- Breakers/Eddies

BD010 -- Breakers

BD010 Breakers
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BD040 -- Eddies

BD040 Eddies
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


HydroA -- Snags/Stumps

HydroA -- Snags/Stumps

BD140 Snags/Stumps
EXS Existence Category
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


InundA -- Land Subject to Inundation

InundA -- Land Subject to Inundation

BH090 Land Subject to Inundation
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HOC Hydrographic Origin Category
  0 Unknown
  1 Controlled
  (5) Natural


LakeresA -- Lake/Pond/Reservoir

LakeresA -- Lake/Pond/Reservoir

BH080 -- Lake/Pond

BH080 Lake/Pond
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (-32768) Null
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SCC Spring/Well Characteristic Category
  (0) Unknown
  9 Freshwater/Potable
  10 Salt
ZV2 Highest Z-value (meters)
  (29999) Unknown

BH130 -- Reservoir

BH130 Reservoir
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  0 Unknown
  (1) Definite
  5 Under Construction
  28 Operational
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SCC Spring/Well Characteristic Category
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null


LockA -- Lock

LockA -- Lock

BI030 Lock
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


MiscA -- Culvert/Water Intake Tower

MiscA -- Culvert/Water Intake Tower

AQ065 -- Culvert

AQ065 Culvert
No attributes except metadata

BI050 -- Water Intake Tower

BI050 Water Intake Tower
No attributes except metadata


SeastrtA -- Breakwater/Groyne/Jetty

SeastrtA -- Breakwater/Groyne/Jetty

BB040 -- Breakwater/Groyne

BB040 Breakwater/Groyne
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does Not Cover (At High Water)

BB140 -- Jetty

BB140 Jetty
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does Not Cover (At High Water)


WatrcrsA -- Water Crossings

WatrcrsA -- Water Crossings

BH020 -- Canal

BH020 Canal
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  32 Navigable
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BH030 -- Ditch

BH030 Ditch
ACC Accuracy Category
  (-32768) Null
EXS Existence Category
  (-32768) Null
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BH140 -- River/Stream

BH140 River/Stream
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  32 Navigable
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


AquedctL -- Aqueduct

AquedctL -- Aqueduct

BH010 Aqueduct
ATC Aqueduct Type Category
  (0) Unknown
  1 Qanat/Kanat/Karez Shaft
  999 Other
  3 Underground Aqueduct
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TRA Traversability
  (0) Unknown
  1 Traversable
  2 Non-Traversable
WID Width (meters)
  (-32768) Null


DamL -- Spillway/Dam/Weir

DamL -- Spillway/Dam/Weir

BH165 -- Spillway

BH165 Spillway
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  20 Composition
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WID Width (meters)
  (-32768) Null

BI020 -- Dam/Weir

BI020 Dam/Weir
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  20 Composition
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  6 Streets
  35 No Transportation Use
WID Width (meters)
  (-32768) Null


DangerL -- Reef

DangerL -- Reef

BD120 Reef
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Info Known
  2 Limits and Info Unknown
MCC Material Composition Category
  (0) Unknown
  24 Coral
  84 Rock/Rocky
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  2 Awash at Sounding Datum
  8 Covers and Uncovers


HazardL -- Cable/Breakers

HazardL -- Cable/Breakers

AT005 -- Cable

AT005 Cable
EXS Existence Category
  6 Abandoned/Disused
  (28) Operational
LOC Location Category
  (4) Below Water Surface
  40 Underground
USE_/USE Usage
  (0) Unknown
  51 Telegraph
  52 Telephone
  53 Power

BD010 -- Breakers

BD010 Breakers
EXS Existence Category
  (-32768) Null
LOC Location Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null


HydroL -- Inland Shoreline

HydroL -- Inland Shoreline

BH210 Inland Shoreline
AHC Associated Hydrographic Category
  (0) Unknown
  1 Perennial
  2 Intermittent
  3 Ephemeral
EXS Existence Category
  (0) Unknown
  44 Approximate/About
  45 Natural
  46 Man-Made
SLT Shoreline Type Category
  (0) Unknown
  6 Mangrove/Nipa
  8 Marsh/Swamp
  10 Rocky
  11 Rubble
  13 Sandy
  14 Stony, Shingly
  999 Other


LockL -- Lock

LockL -- Lock

BI030 Lock
No attributes except metadata


MiscL -- Miscellaneous Line Features

MiscL -- Miscellaneous Line Features

AQ065 -- Culvert

AQ065 Culvert
LOC Location Category
  (-32768) Null

BH100 -- Moat

BH100 Moat
LOC Location Category
  (-32768) Null

BH110 -- Penstock

BH110 Penstock
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground

BI040 -- Sluice Gate

BI040 Sluice Gate
LOC Location Category
  (-32768) Null


RapidsL -- Rapids/Waterfall

RapidsL -- Rapids/Waterfall

BH120 -- Rapids

BH120 Rapids
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BH180 -- Waterfall

BH180 Waterfall
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


SeastrtL -- Sea Structure Lines

SeastrtL -- Sea Structure Lines

BB040 -- Breakwater/Groyne

BB040 Breakwater/Groyne
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does Not Cover (At High Water)
WID Width (meters)
  (-32768) Null

BB140 -- Jetty

BB140 Jetty
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does Not Cover (At High Water)
WID Width (meters)
  (-32768) Null

BB230 -- Seawall

BB230 Seawall
VRR Vertical Reference Category
  (-32768) Null
WID Width (meters)
  (-32768) Null


WatrcrsL -- Water Crossing Lines

WatrcrsL -- Water Crossing Lines

BH020 -- Canal

BH020 Canal
ACC Accuracy Category
  (-32768) Null
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  32 Navigable
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null

BH030 -- Ditch

BH030 Ditch
ACC Accuracy Category
  (-32768) Null
EXS Existence Category
  (-32768) Null
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null

BH140 -- River/Stream

BH140 River/Stream
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  (0) Unknown
  30 Not Isolated
  31 Isolated
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


AquedctP -- Aqueduct

AquedctP -- Aqueduct

BH010 Aqueduct
EXS Existence Category
  6 Abandoned/Disused
  (28) Operational
HYC Hydrological Category
  (-32768) Null
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
SCC Spring/Well Characteristic Category
  (-32768) Null
SWT Well/Spring Type
  (-32768) Null
TRA Traversability
  (0) Unknown
  1 Traversable
  2 Non-Traversable
WFT Well Feature Type
  (-32768) Null


BerthP -- Berth

BerthP -- Berth

BB020 Berth
BER Berth Identifier
  (UNK) Unknown


BotcharP -- Bottom Characteristics

BotcharP -- Bottom Characteristics

BF010 Bottom Characteristics
MCC Material Composition Category
  (0) Unknown
  4 Ash
  8 Boulders
  12 Chalk
  14 Cinders
  15 Cirripedia
  16 Clay
  18 Cobble
  24 Coral
  25 Coral Head
  28 Diatoms
  36 Foraminifera
  37 Fucus
  41 Globigerina
  45 Grass/Thatch
  46 Gravel
  48 Ground
  52 Lava
  58 Madrepores
  59 Manganese
  61 Marl
  63 Mattes
  65 Mud
  66 Mussels
  69 Ooze
  70 Oysters
  73 Pebbles
  75 Polyzoa
  78 Pteropods
  79 Pumice
  80 Quartz
  81 Radiolaria
  84 Rock/Rocky
  88 Sand
  90 Schist
  92 Scoria
  93 Sea-Tangle
  94 Seaweed
  96 Shells
  98 Shingle
  99 Silt
  105 Spicules
  106 Sponge
  108 Stone
  111 Tufa
PSC Physical Surface Characteristics
  (0) Unknown
  1 Broken
  2 Coarse
  3 Decayed
  4 Fine
  5 Gritty
  6 Hard
  7 Rotten
  8 Soft
  9 Sticky
  10 Stiff
  11 Streaky
  12 Tenacious
  13 Uneven
  17 Calcareous
  18 Flinty
  19 Glacial
  20 Ground
  21 Large
  22 Rocky
  23 Small
  24 Speckled
  25 Varied
  26 Volcanic
  27 Medium
  28 Springs in Seabed
  29 Mobile Bottom
MCS Material Composition Secondary
  (0) Unknown
  4 Ash
  8 Boulders
  12 Chalk
  14 Cinders
  15 Cirripedia
  16 Clay
  18 Cobble
  24 Coral
  25 Coral Head
  28 Diatoms
  36 Foraminifera
  37 Fucus
  41 Globigerina
  45 Grass/Thatch
  46 Gravel
  48 Ground
  52 Lava
  58 Madrepores
  59 Manganese
  61 Marl
  63 Mattes
  65 Mud
  66 Mussels
  69 Ooze
  70 Oysters
  73 Pebbles
  75 Polyzoa
  78 Pteropods
  79 Pumice
  80 Quartz
  81 Radiolaria
  84 Rock/Rocky
  88 Sand
  90 Schist
  92 Scoria
  93 Sea-Tangle
  94 Seaweed
  96 Shells
  98 Shingle
  99 Silt
  105 Spicules
  106 Sponge
  108 Stone
  111 Tufa
CSM Secondary Material Characteristics
  (0) Unknown
  1 Broken
  2 Coarse
  3 Decayed
  4 Fine
  5 Gritty
  6 Hard
  7 Rotten
  8 Soft
  9 Sticky
  10 Stiff
  11 Streaky
  12 Tenacious
  13 Uneven
  17 Calcareous
  18 Flinty
  19 Glacial
  20 Ground
  21 Large
  22 Rocky
  23 Small
  24 Speckled
  25 Varied
  26 Volcanic
  27 Medium
MCU Material Composition Underlying
  (0) Unknown
  4 Ash
  8 Boulders
  12 Chalk
  14 Cinders
  15 Cirripedia
  16 Clay
  18 Cobble
  24 Coral
  25 Coral Head
  28 Diatoms
  36 Foraminifera
  37 Fucus
  41 Globigerina
  45 Grass/Thatch
  46 Gravel
  48 Ground
  52 Lava
  58 Madrepores
  59 Manganese
  61 Marl
  63 Mattes
  65 Mud
  66 Mussels
  69 Ooze
  70 Oysters
  73 Pebbles
  75 Polyzoa
  78 Pteropods
  79 Pumice
  80 Quartz
  81 Radiolaria
  84 Rock/Rocky
  88 Sand
  90 Schist
  92 Scoria
  93 Sea-Tangle
  94 Seaweed
  96 Shells
  98 Shingle
  99 Silt
  105 Spicules
  106 Sponge
  108 Stone
  111 Tufa
UMC Underlying Materials Characteristics
  (0) Unknown
  1 Broken
  2 Coarse
  3 Decayed
  4 Fine
  5 Gritty
  6 Hard
  7 Rotten
  8 Soft
  9 Sticky
  10 Stiff
  11 Streaky
  12 Tenacious
  13 Uneven
  17 Calcareous
  18 Flinty
  19 Glacial
  20 Ground
  21 Large
  22 Rocky
  23 Small
  24 Speckled
  25 Varied
  26 Volcanic
  27 Medium


BuoybcnP -- Buoy/Beacon

BuoybcnP -- Buoy/Beacon

BC010 -- Beacon

BC010 Beacon
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
BRF Broadcast Frequency
  (-32768) Null
BR2 Broadcast Frequency (2)
  (-32768) Null
BTC Beacon/Buoy Type Category
  (-32768) Null
CCC Color Code Category
  (0) Unknown
  1 Black (B)
  2 Blue (Bu)
  3 Brown (Br)
  4 Gray (Gy)
  5 Green (G)
  9 Orange (Or)
  12 Red (R)
  14 Violet (Vi)
  15 White (W)
  19 Yellow (Y)
  20 Red & White (RW)
  21 Red & Green (RG)
  22 Red & Black
  23 Red-Green-Red (RGR)
  24 Green & White (GW)
  25 Green & Red (GR)
  26 Green & Black (GB)
  27 Green-Red-Green (GRG)
  28 Green-Yellow-Black (GYB)
  29 Yellow & Black (YB)
  30 Yellow-Black-Yellow (YBY)
  31 Yellow & Red (YR)
  32 Yellow & Green (YG)
  33 Yellow-Red-White
  34 Black & Yellow (BY)
  35 Black-Yellow-Black
  36 Black-Red-Black (BRB)
  37 Black & White (BW)
  38 Black & Red (BR)
  39 Black & Green (BG)
  40 White & Red (WR)
  41 White & Orange (WOr)
  42 White & Green (WG)
  43 White & Black (WB)
  44 White & Yellow (WY)
  45 White-Red-Green (WRG)
  46 White-Green-White (WGW)
COL Character of Light
  (N/A) Null
EOL Elevation of Light
  (-32768) Null
MLR Multiple Light Ranges
  (N/A) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
NS2 Navigation System Types (2)
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
ORC Operating Range Category
  (-32768) Null
OR2 Operating Range Category (2)
  (-32768) Null
REF Radar Reflector Attribute
  1 Radar Reflector Present
  (2) Radar Reflector Absent
SSC Structure Shape Category
  (-32768) Null
SST Sound Signal Type
  0 Unknown
  1 Bell
  2 Diaphone
  3 Explosive Fog Signal
  4 Gong
  6 Horn
  9 Siren
  14 Whistle
  15 Reed
  (16) None
TMC Top Mark Characteristic
  0 Unknown
  1 East Mark (2 cones base together)
  2 Isolated Danger (2 balls)
  3 North Mark (2 cones pointing up)
  6 Special (X)
  8 South Mark (2 cones pointing down)
  9 West Mark (2 cones points together)
  15 Ball Over Cone
  16 Cone Over Ball
  17 Broom Point Up
  18 Perch
  19 Diamond
  21 Cone, Point Upwards
  22 Cone (Point Downwards)
  23 Upright Cross
  25 Can (Open)
  26 Can (Filled)
  27 Ball (Open)
  28 Ball (Filled)
  29 Can Over Ball (Open)
  30 Cross Over Ball (Open)
  31 Diamond Over Ball (Filled)
  32 Double Cone, Points Apart (Open)
  (33) None
TXT Text Attribute
  (UNK) Unknown

BC020 -- Buoy

BC020 Buoy
ACC Accuracy Category
  (-32768) Null
BRF Broadcast Frequency
  (-32768) Null
BR2 Broadcast Frequency (2)
  (-32768) Null
BTC Beacon/Buoy Type Category
  (0) Unknown
  4 Large Navigational Buoy (LANDBY)
  6 Light Float
  7 Mooring
  10 Ocean Data Aquisition System (ODAS)
  35 Articulated Lights
CCC Color Code Category
  (0) Unknown
  1 Black (B)
  2 Blue (Bu)
  3 Brown (Br)
  4 Gray (Gy)
  5 Green (G)
  9 Orange (Or)
  12 Red (R)
  14 Violet (Vi)
  15 White (W)
  19 Yellow (Y)
  20 Red & White (RW)
  21 Red & Green (RG)
  22 Red & Black
  23 Red-Green-Red (RGR)
  24 Green & White (GW)
  25 Green & Red (GR)
  26 Green & Black (GB)
  27 Green-Red-Green (GRG)
  28 Green-Yellow-Black (GYB)
  29 Yellow & Black (YB)
  30 Yellow-Black-Yellow (YBY)
  31 Yellow & Red (YR)
  32 Yellow & Green (YG)
  33 Yellow-Red-White
  34 Black & Yellow (BY)
  35 Black-Yellow-Black
  36 Black-Red-Black (BRB)
  37 Black & White (BW)
  38 Black & Red (BR)
  39 Black & Green (BG)
  40 White & Red (WR)
  41 White & Orange (WOr)
  42 White & Green (WG)
  43 White & Black (WB)
  44 White & Yellow (WY)
  45 White-Red-Green (WRG)
  46 White-Green-White (WGW)
COL Character of Light
  (N/A) Null
EOL Elevation of Light
  (-32768) Null
MLR Multiple Light Ranges
  (N/A) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
NS2 Navigation System Types (2)
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
ORC Operating Range Category
  (-32768) Null
OR2 Operating Range Category (2)
  (-32768) Null
REF Radar Reflector Attribute
  1 Radar Reflector Present
  (2) Radar Reflector Absent
SSC Structure Shape Category
  (0) Unknown
  1 Barrel, Ton
  6 Conical/Peaked/NUN
  7 Cylindrical
  10 Pillar, Spindle
  16 Spar
  17 Spherical (Hemispherical)
  73 Superbuoy
  85 Diamond-Shaped Buoy
  999 Other
SST Sound Signal Type
  0 Unknown
  1 Bell
  2 Diaphone
  3 Explosive Fog Signal
  4 Gong
  6 Horn
  9 Siren
  14 Whistle
  15 Reed
  (16) None
TMC Top Mark Characteristic
  0 Unknown
  1 East Mark (2 cones base together)
  2 Isolated Danger (2 balls)
  3 North Mark (2 cones pointing up)
  6 Special (X)
  8 South Mark (2 cones pointing down)
  9 West Mark (2 cones points together)
  15 Ball Over Cone
  16 Cone Over Ball
  17 Broom Point Up
  18 Perch
  19 Diamond
  21 Cone, Point Upwards
  22 Cone (Point Downwards)
  23 Upright Cross
  25 Can (Open)
  26 Can (Filled)
  27 Ball (Open)
  28 Ball (Filled)
  29 Can Over Ball (Open)
  30 Cross Over Ball (Open)
  31 Diamond Over Ball (Filled)
  32 Double Cone, Points Apart (Open)
  (33) None
TXT Text Attribute
  (UNK) Unknown

BC070 -- Light Vessel/Lightship

BC070 Light Vessel/Lightship
ACC Accuracy Category
  (-32768) Null
BRF Broadcast Frequency
  (-32768) Null
BR2 Broadcast Frequency (2)
  (-32768) Null
BTC Beacon/Buoy Type Category
  (-32768) Null
CCC Color Code Category
  (-32768) Null
COL Character of Light
  (UNK) Unknown
EOL Elevation of Light
  (0) Unknown
MLR Multiple Light Ranges
  (N/A) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
NS2 Navigation System Types (2)
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
ORC Operating Range Category
  (-32768) Null
OR2 Operating Range Category (2)
  (-32768) Null
REF Radar Reflector Attribute
  1 Radar Reflector Present
  (2) Radar Reflector Absent
SSC Structure Shape Category
  (-32768) Null
SST Sound Signal Type
  0 Unknown
  1 Bell
  2 Diaphone
  3 Explosive Fog Signal
  4 Gong
  6 Horn
  9 Siren
  14 Whistle
  15 Reed
  (16) None
TMC Top Mark Characteristic
  (-32768) Null
TXT Text Attribute
  (UNK) Unknown


CisternP -- Cistern

CisternP -- Cistern

BI010 Cistern
No attributes except metadata


DamP -- Spillway/Dam/Weir

DamP -- Spillway/Dam/Weir

BH165 -- Spillway

BH165 Spillway
LEN_/LEN Length/Diameter
  (-32768) Null
WID Width (meters)
  (-32768) Null

BI020 -- Dam/Weir

BI020 Dam/Weir
LEN_/LEN Length/Diameter
  (-32768) Null
WID Width (meters)
  (-32768) Null


DangerP -- Danger Points

DangerP -- Danger Points

BD100 -- Pile/Piling/Post

BD100 Pile/Piling/Post
ARE_/ARE Area
  (0) Unknown
HDI Hydrographic Depth/Height Information
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
  8 Covers and Uncovers

BD130 -- Rock

BD130 Rock
ARE_/ARE Area
  (-32768) Null
HDI Hydrographic Depth/Height Information
  (0) Unknown
  9 Depth Known by Other Than Wire Drag
  10 Depth Known by Wire Drag
  12 Depth Unknown
  13 Uncovering Height Known
  14 Uncovering Height Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  24 Coral
  84 Rock/Rocky
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
  8 Covers and Uncovers

BD180 -- Wreck

BD180 Wreck
ARE_/ARE Area
  (-32768) Null
HDI Hydrographic Depth/Height Information
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  0 Unknown
  (13) Hull Showing
  14 Mast Showing
  20 Funnel Showing
  21 Superstructure Showing
  28 Mast and Funnel Showing
MCC Material Composition Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  0 Unknown
  (1) Above Surface/Does not cover (At High Water)
  8 Covers and Uncovers


HazardP -- Underwater Danger/Hazard/Crib

HazardP -- Underwater Danger/Hazard/Crib

BD000 -- Underwater Danger/Hazard

BD000 Underwater Danger/Hazard
No attributes except metadata

BD020 -- Crib

BD020 Crib
No attributes except metadata


HydObstrucP -- Hydrographic Obstruction Points

HydObstrucP -- Hydrographic Obstruction Points

BD010 -- Breakers

BD010 Breakers
No attributes except metadata

BD040 -- Eddies

BD040 Eddies
No attributes except metadata

BD070 -- Obstruction (Nautical)

BD070 Obstruction (Nautical)
No attributes except metadata


HydroP -- Current Arrow

HydroP -- Current Arrow

BG010 Current Arrow
AOO Angle of Orientation (degrees)
  (0) Unknown
CUR Current Type Category
  0 Unknown
  2 Flood
  3 General Flow
  (4) River Flow
  5 Ocean Flow
SGC Gradient/Slope (percent)
  (0) Unknown


LandingP -- Landing Place

LandingP -- Landing Place

BB150 Landing Place
COD Certainty of Delineation
  (1) Limits and Info Known
  2 Limits and Info Unknown
EXS Existence Category
  (0) Unknown
  45 Natural
  46 Man-made


LightsP -- Light

LightsP -- Light

BC040 Light
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
BRF Broadcast Frequency
  (-32768) Null
BR2 Broadcast Frequency (2)
  (-32768) Null
CCC Color Code Category
  (0) Unknown
  1 Black (B)
  2 Blue (Bu)
  3 Brown (Br)
  4 Gray (Gy)
  5 Green (G)
  9 Orange (Or)
  12 Red (R)
  14 Violet (Vi)
  15 White (W)
  19 Yellow (Y)
  20 Red & White (RW)
  21 Red & Green (RG)
  22 Red & Black
  23 Red-Green-Red (RGR)
  24 Green & White (GW)
  25 Green & Red (GR)
  26 Green & Black (GB)
  27 Green-Red-Green (GRG)
  28 Green-Yellow-Black (GYB)
  29 Yellow & Black (YB)
  30 Yellow-Black-Yellow (YBY)
  31 Yellow & Red (YR)
  32 Yellow & Green (YG)
  33 Yellow-Red-White
  34 Black & Yellow (BY)
  35 Black-Yellow-Black
  36 Black-Red-Black (BRB)
  37 Black & White (BW)
  38 Black & Red (BR)
  39 Black & Green (BG)
  40 White & Red (WR)
  41 White & Orange (WOr)
  42 White & Green (WG)
  43 White & Black (WB)
  44 White & Yellow (WY)
  45 White-Red-Green (WRG)
  46 White-Green-White (WGW)
COL Character of Light
  (UNK) Unknown
HLT Hydrographic Light Type
  (0) Unknown
  1 Sectored Light
  999 Other
  3 Moire Effect Light
  5 Occasional
IAC IALA Aid Category
  (0) Unknown
  1 Non-IALA Aid
  2 IALA Aid
MLR Multiple Light Ranges
  (N/A) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
NS2 Navigation System Types (2)
  0 Unknown
  1 Circular Radiobeacon (RC)
  4 Radio Direction Finding
  5 Directional Radiobeacon (RD)
  10 Racon (Radar Responder Beacon)
  17 NDB (Non-Directional Beacon)
  41 Rotating Loop Radiobeacon
  45 Radar Station (Ra)
  51 Radiobeacon, Type Unknown (R Bn)
  (52) None
  53 QTG Station (R)
  54 Ramark (Ramark)
REF Radar Reflector Attribute
  1 Radar Reflector Present
  (2) Radar Reflector Absent
SST Sound Signal Type
  0 Unknown
  1 Bell
  2 Diaphone
  3 Explosive Fog Signal
  4 Gong
  6 Horn
  9 Siren
  14 Whistle
  15 Reed
  (16) None
TMC Top Mark Characteristic
  0 Unknown
  1 East Mark (2 cones base together)
  2 Isolated Danger (2 balls)
  3 North Mark (2 cones pointing up)
  6 Special (X)
  8 South Mark (2 cones pointing down)
  9 West Mark (2 cones points together)
  15 Ball Over Cone
  16 Cone Over Ball
  17 Broom Point Up
  18 Perch
  19 Diamond
  21 Cone, Point Upwards
  22 Cone (Point Downwards)
  23 Upright Cross
  25 Can (Open)
  26 Can (Filled)
  27 Ball (Open)
  28 Ball (Filled)
  29 Can Over Ball (Open)
  30 Cross Over Ball (Open)
  31 Diamond Over Ball (Filled)
  32 Double Cone, Points Apart (Open)
  (33) None
TXT Text Attribute
  (None) None


LoadingP -- Platform/Offshore Loading Facility

LoadingP -- Platform/Offshore Loading Facility

BD110 -- Platform

BD110 Platform
No attributes except metadata

BB170 -- Offshore Loading Facility

BB170 Offshore Loading Facility
No attributes except metadata


LockP -- Lock

LockP -- Lock

BI030 Lock
No attributes except metadata


MineP -- Mine (Naval)

MineP -- Mine (Naval)

BD001 Mine (Naval)
ACC Accuracy Category
  (0) Unknown
  1 Accurate
  2 Approximate
COE Certainty of Existence
  (0) Unknown
  1 Definite
  2 Doughtful
  3 Reported
LOC Location Category
  (0) Unknown
  15 On Water Surface/Floating
  17 Sunken / On sea bottom
  23 Below Sea bottom
  24 Suspended or Elevated above sea bottom
  39 Depth Unknown
TXT Text Attribute
  (UNK) Unknown


MiscP -- Sluice Gate/Water Intake Tower

MiscP -- Sluice Gate/Water Intake Tower

BI040 -- Sluice Gate

BI040 Sluice Gate
LEN_/LEN Length/Diameter
  (-32768) Null
WID Width (meters)
  (-32768) Null

BI050 -- Water Intake Tower

BI050 Water Intake Tower
LEN_/LEN Length/Diameter
  (-32768) Null
WID Width (meters)
  (-32768) Null


RapidsP -- Rapids Points

RapidsP -- Rapids Points

BH120 -- Rapids

BH120 Rapids
EXS Existence Category
  (-32768) Null
HFC Hydrographic Form Category
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null

BH145 -- River/Stream Vanishing Point

BH145 River/Stream Vanishing Point
EXS Existence Category
  (-32768) Null
HFC Hydrographic Form Category
  0 Unknown
  (2) Disappearing
  16 Dissipating
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null

BH180 -- Waterfall

BH180 Waterfall
EXS Existence Category
  (-32768) Null
HFC Hydrographic Form Category
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


SoundP -- Sounding

SoundP -- Sounding

BE020 Sounding
ACC Accuracy Category
  (1) Accurate
  2 Approximate
  3 Doubtful
CDP Calendar Date Type
  (26) Information as of _____
EXS Existence Category
  (1) Definite
  2 Doubtful
  3 Reported
HDH Hydrographic Drying Height
  (-32768) Null
HDP Hydrographic Depth
  (0) Unknown
SND Sounding Category
  1 Drying Heights
  2 No Bottom Found
  9 Slant
  (10) Ordinary
  999 Other
SVC Sounding Velocity
  (0) Unknown
  1 Echo Sounder Calibrated at 4800 ft/sec Uncorrected
  2 Echo Sounder Calibrated at 1500 m/sec Uncorrected
  3 Mathews Tables (NP 139) Corrected
  4 SVM Corrected
  5 Other Calibration
VAL Value
  (0) MinValue
  32767 MaxValue


SpringP -- Fountain/Spring/Water Hole

SpringP -- Fountain/Spring/Water Hole

BH075 -- Fountain

BH075 Fountain
EXS Existence Category
  0 Unknown
  3 Reported
  6 Abandoned/Disused
  (28) Operational
HYC Hydrological Category
  0 Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  (8) Perennial/Permanent
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
SCC Spring/Well Characteristic Category
  (0) Unknown
  1 Alkaline
  2 Not Applicable
  4 Mineral
  9 Freshwater/Potable
SWT Well/Spring Type
  (-32768) Null
TRA Traversability
  (-32768) Null
WFT Well Feature Type
  (-32768) Null

BH170 -- Spring/Water Hole

BH170 Spring/Water Hole
EXS Existence Category
  0 Unknown
  3 Reported
  6 Abandoned/Disused
  (28) Operational
HYC Hydrological Category
  (0) Unknown
  3 Dry
  6 Non-Perennial/Intermittent/Fluctuating
  8 Perennial/Permanent
LOC Location Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
SCC Spring/Well Characteristic Category
  (0) Unknown
  1 Alkaline
  2 Not Applicable
  4 Mineral
  9 Freshwater/Potable
SWT Well/Spring Type
  (0) Unknown
  1 Geyser
  4 Artesian
  5 Waterhole
  6 Walled-in Spring
TRA Traversability
  (-32768) Null
WFT Well Feature Type
  (-32768) Null


AgristrA -- Agricultural Storage

AgristrA -- Agricultural Storage

AM020 -- Grain/Bin/Silo

AM020 Grain/Bin/Silo
HGT Height Above Surface Level (meters)
  (-32768) Null
IDN Identification Number
  (-32768) Null
LOC Location Category
  (0) Unknown
  8 On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AM030 -- Grain Elevator

AM030 Grain Elevator
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


CmpxindA -- Complex Outline Area

CmpxindA -- Complex Outline Area

AL045 Complex Outline Area
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
BFC Building Function Category
  (0) Unknown
  1 Fabrication Structures
  2 Government Building
  3 Capitol Building
  4 Castle
  5 Government Administration Building
  6 Hospital
  7 House of Worship
  8 Military Administration/Operations Building
  9 Museum
  10 Observatory
  11 Palace
  12 Police Station
  13 Prison
  14 Ranger Station
  15 School
  16 House
  17 Multi-Unit Dwelling
  18 Cemetery Building
  19 Farm Building
  20 Greenhouse
  21 Garage
  22 Watermill/Gristmill
  23 Wind Tunnel
  24 Warehouse
  25 Roundhouse
  26 R/R Storage/Repair Facility
  27 Depot Terminal
  28 Administration Building
  29 Aircraft Maintenance Shop
  30 Hangar
  31 Custom House
  33 Health Office
  35 Post Office
  36 Barracks/Dormitory
  37 Fire Station
  51 Market
  53 Bank
  54 Service/Refueling Station
  57 Restaurant
  59 R&D Lab/Research Facility
  60 University/College
  61 Courthouse
  66 Embassy
  69 Guard Shack/Guard Room
  70 Kennel
  77 Harbor Masters Office
  82 Lighthouse
  83 Power Generation
  85 Newspaper Plant
  86 Telephone Exchange (Main)
  87 Auditorium
  88 Opera House
  89 Processing/Treatment
  90 Pumphouse
  91 Mobile Home
  92 Weather Station
  93 Dependent's Housing/Bivouac Area
  95 Hotel
  96 Diplomatic Building
  98 Shed
  109 Senior citizen's Home
  116 Factory
  120 Automobile Plant
  151 Dormitory
  122 Shopping Center
  128 Library
  133 Commercial Building
  1001 Meeting Place
  1002 Polling Station
  1003 Executive Office
  1004 Ministerial Office
  1005 Human and Social Service Office
  1006 Correctional Institution
  999 Other
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  28 Operational
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (0) Unknown
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  22 Offshore
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  13 Chemical
  19 Coke
  64 Metal
  95 Sewage
  997 Not Applicable
  999 Other
USE_/USE Usage
  (0) Unknown
  5 State
  6 Private
  8 Military
  22 Joint Military/Civilian
  23 International
  43 Institutional
  49 Civilian/Public


DisposeA -- Disposal Sites

DisposeA -- Disposal Sites

AB000 -- Disposal Site/Waste Pile

AB000 Disposal Site/Waste Pile
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
PRO Product Category
  (0) Unknown
  101 Slag
  127 Tailings
  128 Refuse

AB010 -- Wrecking Yard/Scrap Yard

AB010 Wrecking Yard/Scrap Yard
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
PRO Product Category
  (-32768) Null


ExtractA -- Extraction Areas

ExtractA -- Extraction Areas

AA010 -- Mine

AA010 Mine
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MIN_/MIN Mining Category
  (0) Unknown
  2 Horizontal Shaft
  3 Open Pit
  4 Placer
  5 Prospect
  6 Strip
  7 Vertical Shaft
  8 Peat Cuttings
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  16 Clay
  17 Coal
  23 Copper
  42 Gold
  46 Gravel
  51 Iron
  54 Lead
  84 Rock/Rocky
  87 Salt
  88 Sand
  100 Silver
  112 Uranium
  118 Zinc
  119 Bauxite
  999 Other

AA012 -- Quarry

AA012 Quarry
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MIN_/MIN Mining Category
  (0) Unknown
  2 Horizontal Shaft
  3 Open Pit
  4 Placer
  5 Prospect
  6 Strip
  7 Vertical Shaft
  8 Peat Cuttings
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  16 Clay
  17 Coal
  23 Copper
  42 Gold
  46 Gravel
  51 Iron
  54 Lead
  84 Rock/Rocky
  87 Salt
  88 Sand
  100 Silver
  112 Uranium
  118 Zinc
  119 Bauxite
  999 Other

AA052 -- Oil/Gas Field

AA052 Oil/Gas Field
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
EXS Existence Category
  (-32768) Null
MIN_/MIN Mining Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null

BH155 -- Salt Evaporator

BH155 Salt Evaporator
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
EXS Existence Category
  (-32768) Null
MIN_/MIN Mining Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null


NuclearA -- Nuclear Sites

NuclearA -- Nuclear Sites

AF030 -- Cooling Tower

AF030 Cooling Tower
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null

AL140 -- Particle Accelerator

AL140 Particle Accelerator
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null


ProcessA -- Processing Facilities

ProcessA -- Processing Facilities

AC000 -- Processing/Treatment Plant

AC000 Processing/Treatment Plant
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  2 Aluminum
  5 Asphalt
  9 Brick
  11 Cement
  13 Chemical
  19 Coke
  23 Copper
  33 Explosives
  39 Gasoline
  40 Glass
  42 Gold
  50 Heat
  51 Iron
  54 Lead
  56 Lumber
  64 Metal
  67 Oil
  71 Paper
  82 Radioactive Material
  85 Rubber
  95 Sewage
  100 Silver
  107 Steel
  112 Uranium
  113 Vegetation Products
  116 Water
  118 Zinc
  999 Other

AC010 -- Blast Furnace

AC010 Blast Furnace
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null

AC040 -- Oil/Gas Facilities

AC040 Oil/Gas Facilities
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null

AE010 -- Assembly Plant

AE010 Assembly Plant
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null


StorageA -- Storage Facilities

StorageA -- Storage Facilities

AM010 -- Depot Storage

AM010 Depot Storage
HGT Height Above Surface Level (meters)
  (-32768) Null
IDN Identification Number
  (0) Unknown
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public

AM060 -- Storage Bunker/Storage Mound

AM060 Storage Bunker/Storage Mound
HGT Height Above Surface Level (meters)
  (-32768) Null
IDN Identification Number
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  1 Aircraft
  3 Ammunition
  33 Explosives
  39 Gasoline
  82 Radioactive Material
  112 Uranium
  131 Personnel
USE_/USE Usage
  (-32768) Null

AM070 -- Tank

AM070 Tank
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (0) Unknown
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  13 Chemical
  35 Food
  38 Gas
  39 Gasoline
  67 Oil
  116 Water
  999 Other
USE_/USE Usage
  (0) Unknown

AM080 -- Water Tower

AM080 Water Tower
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public

AM999 -- Hazardous Materials Storage

AM999 Hazardous Materials Storage
HGT Height Above Surface Level (meters)
  (-32768) Null
IDN Identification Number
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null


TreatA -- Treatment Areas

TreatA -- Treatment Areas

AC030 -- Settling Basin/Sludge Pond

AC030 Settling Basin/Sludge Pond
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  2 Aluminum
  5 Asphalt
  9 Brick
  11 Cement
  13 Chemical
  19 Coke
  23 Copper
  33 Explosives
  39 Gasoline
  40 Glass
  42 Gold
  50 Heat
  51 Iron
  54 Lead
  56 Lumber
  64 Metal
  67 Oil
  71 Paper
  82 Radioactive Material
  85 Rubber
  95 Sewage
  100 Silver
  107 Steel
  112 Uranium
  113 Vegetation Products
  116 Water
  118 Zinc
  999 Other

AJ030 -- Feedlot/Stockyard/Holding Pen

AJ030 Feedlot/Stockyard/Holding Pen
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null

BH040 -- Filtration/Aeration Beds

BH040 Filtration/Aeration Beds
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null

BH050 -- Fish Hatchery/Fish Farm/Marine Farm

BH050 Fish Hatchery/Fish Farm/Marine Farm
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (134) Fish


VehicleStorageA -- Vehicle Storage Area/Parking Area

VehicleStorageA -- Vehicle Storage Area/Parking Area

AQ140 Vehicle Storage Area/Parking Area
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


ExtractL -- Mine/Quarry

ExtractL -- Mine/Quarry

AA010 -- Mine

AA010 Mine
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
MIN_/MIN Mining Category
  (0) Unknown
  2 Horizontal Shaft
  3 Open Pit
  4 Placer
  5 Prospect
  6 Strip
  7 Vertical Shaft
  8 Peat Cuttings
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  16 Clay
  17 Coal
  23 Copper
  42 Gold
  46 Gravel
  51 Iron
  54 Lead
  84 Rock/Rocky
  87 Salt
  88 Sand
  100 Silver
  112 Uranium
  118 Zinc
  119 Bauxite
  999 Other

AA012 -- Quarry

AA012 Quarry
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  28 Operational
MIN_/MIN Mining Category
  (0) Unknown
  2 Horizontal Shaft
  3 Open Pit
  4 Placer
  5 Prospect
  6 Strip
  7 Vertical Shaft
  8 Peat Cuttings
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  16 Clay
  17 Coal
  23 Copper
  42 Gold
  46 Gravel
  51 Iron
  54 Lead
  84 Rock/Rocky
  87 Salt
  88 Sand
  100 Silver
  112 Uranium
  118 Zinc
  119 Bauxite
  999 Other


IndL -- Industrial Lines

IndL -- Industrial Lines

AF020 -- Conveyor

AF020 Conveyor
LOC Location Category
  (-32768) Null

BH060 -- Flume

BH060 Flume
LOC Location Category
  (0) Unknown
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground

FA090 -- Geophysical Prospect Grid Line

FA090 Geophysical Prospect Grid Line
LOC Location Category
  (-32768) Null


AgristrP -- Agricultural Storage

AgristrP -- Agricultural Storage

AM030 -- Grain Elevator

AM030 Grain Elevator
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LEN_/LEN_ Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
WID Width (meters)
  (-32768) Null

AM020 -- Grain/Bin/Silo

AM020 Grain/Bin/Silo
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (0) Unknown
  8 On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
WID Width (meters)
  (-32768) Null


ExtractP -- Extraction Sites

ExtractP -- Extraction Sites

AA010 -- Mine

AA010 Mine
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MIN_/MIN Mining Category
  (0) Unknown
  2 Horizontal Shaft
  3 Open Pit
  4 Placer
  5 Prospect
  6 Strip
  7 Vertical Shaft
  8 Peat Cuttings
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  16 Clay
  17 Coal
  23 Copper
  42 Gold
  46 Gravel
  51 Iron
  54 Lead
  84 Rock/Rocky
  87 Salt
  88 Sand
  100 Silver
  112 Uranium
  118 Zinc
  119 Bauxite
  999 Other
WID Width (meters)
  (-32768) Null

AA012 -- Quarry

AA012 Quarry
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MIN_/MIN Mining Category
  0 Unknown
  2 Horizontal Shaft
  (3) Open Pit
  4 Placer
  5 Prospect
  6 Strip
  7 Vertical Shaft
  8 Peat Cuttings
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  16 Clay
  17 Coal
  23 Copper
  42 Gold
  46 Gravel
  51 Iron
  54 Lead
  84 Rock/Rocky
  87 Salt
  88 Sand
  100 Silver
  112 Uranium
  118 Zinc
  119 Bauxite
  999 Other
WID Width (meters)
  (-32768) Null

AA052 -- Oil/Gas Field

AA052 Oil/Gas Field
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (-32768) Null
MIN_/MIN Mining Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (N/A) Null
NFN Name Identifier
  (N/A) Null
PRO Product Category
  (-32768) Null
WID Width (meters)
  (-32768) Null


IndP -- Timber Yard

IndP -- Timber Yard

AM031 Timber Yard
TXT Text Attribute
  (UNK) Unknown


NuclearP -- Particle Accelerator

NuclearP -- Particle Accelerator

AL140 Particle Accelerator
No attributes except metadata


ObstrP -- Obstructions

ObstrP -- Obstructions

AF010 -- Chimney/Smokestack

AF010 Chimney/Smokestack
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
TTC Tower Type Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null

AF030 -- Cooling Tower

AF030 Cooling Tower
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
TTC Tower Type Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null

AF040 -- Crane

AF040 Crane
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
TTC Tower Type Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null

AF070 -- Flare Pipe

AF070 Flare Pipe
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
TTC Tower Type Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null

AJ050 -- Windmill

AJ050 Windmill
HGT Height Above Surface Level (meters)
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
TTC Tower Type Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null


ProcessP -- Processing/Treatment Facilities

ProcessP -- Processing/Treatment Facilities

AC000 -- Processing/Treatment Plant

AC000 Processing/Treatment Plant
ARE_/ARE Area
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  2 Aluminum
  5 Asphalt
  9 Brick
  11 Cement
  13 Chemical
  19 Coke
  23 Copper
  33 Explosives
  39 Gasoline
  40 Glass
  42 Gold
  50 Heat
  51 Iron
  54 Lead
  56 Lumber
  64 Metal
  67 Oil
  71 Paper
  82 Radioactive Material
  85 Rubber
  95 Sewage
  100 Silver
  107 Steel
  112 Uranium
  113 Vegetation Products
  116 Water
  118 Zinc
  999 Other

AC010 -- Blast Furnace

AC010 Blast Furnace
ARE_/ARE Area
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null

AE010 -- Assembly Plant

AE010 Assembly Plant
ARE_/ARE Area
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null


RigwellP -- Rigs and Wells

RigwellP -- Rigs and Wells

AA040 -- Rig/Superstructure

AA040 Rig/Superstructure
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
LOC Location Category
  (0) Unknown
  22 Offshore
  40 Underground
  999 Other
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  38 Gas
  67 Oil
  116 Water
SCC Spring/Well Characteristic Category
  (-32768) Null
WFT Well Feature Type
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null

AA050 -- Well

AA050 Well
EXS Existence Category
  0 Unknown
  3 Reported
  6 Abandoned/Disused
  (28) Operational
HGT Height Above Surface Level (meters)
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  38 Gas
  67 Oil
  116 Water
SCC Spring/Well Characteristic Category
  (0) Unknown
  1 Alkaline
  2 Not Applicable
  4 Mineral
  9 Freshwater/Potable
WFT Well Feature Type
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null

AC020 -- Catalytic Cracker

AC020 Catalytic Cracker
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
LOC Location Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
SCC Spring/Well Characteristic Category
  (-32768) Null
WFT Well Feature Type
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null


StorageP -- Storage Sites

StorageP -- Storage Sites

AM010 -- Depot Storage

AM010 Depot Storage
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
WID Width (meters)
  (-32768) Null

AM060 -- Storage Bunker/Storage Mound

AM060 Storage Bunker/Storage Mound
HGT Height Above Surface Level (meters)
  (-32768) Null
IDN Identification Number
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  1 Aircraft
  3 Ammunition
  33 Explosives
  39 Gasoline
  82 Radioactive Material
  112 Uranium
  131 Personnel
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
WID Width (meters)
  (-32768) Null

AM070 -- Tank

AM070 Tank
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  13 Chemical
  38 Gas
  39 Gasoline
  67 Oil
  116 Water
  999 Other
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
WID Width (meters)
  (-32768) Null

AM080 -- Water Tower

AM080 Water Tower
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
WID Width (meters)
  (-32768) Null

AM999 -- Hazardous Materials Storage

AM999 Hazardous Materials Storage
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
USE_/USE Usage
  (-32768) Null
WID Width (meters)
  (-32768) Null


TowerP -- Tower (Non-Communication)

TowerP -- Tower (Non-Communication)

AL240 Tower (Non-Communication)
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (0) Unknown
LEN_/LEN Length/Diameter
  (29999) Unknown
TTC Tower Type Category
  (0) Unknown
  1 Bridge
  2 Observation/Lookout
  999 Other
USE_/USE Usage
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported


TreatP -- Feedlot/Stockyard/Holding Pen

TreatP -- Feedlot/Stockyard/Holding Pen

AJ030 Feedlot/Stockyard/Holding Pen
TXT Text Attribute
  (N/A) Null


EmbankA -- Embankment/Fill Area

EmbankA -- Embankment/Fill Area

DB090 Embankment/Fill Area
HGT Height Above Surface Level (meters)
  (29999) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  69 Levee/Dike
  127 Levee/Dike as a Causeway
  136 Levee/Dike as a Fill
  999 Other
VRR Vertical Reference Category
  (-32768) Null


GroundA -- Ground Surface Element

GroundA -- Ground Surface Element

DA010 Ground Surface Element
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  30 Earthen
  46 Gravel
  52 Lava
  55 Loess
  65 Mud
  84 Rock/Rocky
  88 Sand
  104 Soil
  999 Other
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


LandIceA -- Glacier/Snow/Ice Field

LandIceA -- Glacier/Snow/Ice Field

BJ030 -- Glacier

BJ030 Glacier
SIC Snow/Ice Category
  (-32768) Null

BJ100 -- Snow/Ice Field

BJ100 Snow/Ice Field
SIC Snow/Ice Category
  (1) snow
  2 ice


Lndfrm1A -- Landform 1 Areas

Lndfrm1A -- Landform 1 Areas

BH150 -- Salt Pan

BH150 Salt Pan
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SDO Sand Dune Orientation (degrees)
  (-32768) Null
SSC Structure Shape Category
  (-32768) Null

BH160 -- Sebkha

BH160 Sebkha
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SDO Sand Dune Orientation (degrees)
  (-32768) Null
SSC Structure Shape Category
  (-32768) Null

DB030 -- Cave

DB030 Cave
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SDO Sand Dune Orientation (degrees)
  (-32768) Null
SSC Structure Shape Category
  (-32768) Null

DB170 -- Sand Dunes/Sand Hills

DB170 Sand Dunes/Sand Hills
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SDO Sand Dune Orientation (degrees)
  (999) Unknown
SSC Structure Shape Category
  (0) Unknown
  22 Crescent
  26 Lateral
  27 Mounds
  28 Ripple
  29 Star
  30 Transverse

DB200 -- Gully/Gorge

DB200 Gully/Gorge
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SDO Sand Dune Orientation (degrees)
  (-32768) Null
SSC Structure Shape Category
  (-32768) Null


Lndfrm2A -- Landform 2 Areas

Lndfrm2A -- Landform 2 Areas

Subtypes in this feature class include:

  • BJ020 -- Moraine
  • DB060 -- Crevice/Crevasse
  • DB160 -- Rock Strata/Rock Formation

BJ020 -- Moraine

BJ020 Moraine
HGT Height Above Surface Level (meters)
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
WID Width (meters)
  (-32768) Null

DB060 -- Crevice/Crevasse

DB060 Crevice/Crevasse
HGT Height Above Surface Level (meters)
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  30 Earthen
  103 Snow/Ice
WID Width (meters)
  (-32768) Null

DB160 -- Rock Strata/Rock Formation

DB160 Rock Strata/Rock Formation
HGT Height Above Surface Level (meters)
  (29999) Unknown
MCC Material Composition Category
  (-32768) Null
WID Width (meters)
  (-32768) Null


PhysA -- Volcano

PhysA -- Volcano

DB180 Volcano
HGT Height Above Surface Level (meters)
  (29999) Unknown
LOC Location Category
  (8) On Ground Surface
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VGT Volcanic Geologic Type
  0 Unknown
  (1) Volcano
  2 Cinder Cone
  3 Shield
  4 Caldera
  5 Composite


SeaiceA -- Sea/Ice Areas

SeaiceA -- Sea/Ice Areas

BJ065 -- Ice Shelf

BJ065 Ice Shelf
PRC Periodic Restriction Category
  (-32768) Null

BJ070 -- Pack Ice

BJ070 Pack Ice
PRC Periodic Restriction Category
  (0) Unknown
  3 Permanent Ice
  4 Seasonal limit - Jan.
  5 Seasonal limit - Feb.
  6 Seasonal limit - Mar.
  7 Seasonal limit - Apr.
  8 Seasonal limit - May
  9 Seasonal limit - Jun.
  10 Seasonal limit - Jul.
  11 Seasonal limit - Aug.
  12 Seasonal limit - Sep.
  13 Seasonal limit - Oct.
  14 Seasonal limit - Nov.
  15 Seasonal limit - Dec.
  999 Other

BJ080 -- Polar Ice

BJ080 Polar Ice
PRC Periodic Restriction Category
  (0) Unknown
  3 Permanent Ice
  4 Seasonal limit - Jan.
  5 Seasonal limit - Feb.
  6 Seasonal limit - Mar.
  7 Seasonal limit - Apr.
  8 Seasonal limit - May
  9 Seasonal limit - Jun.
  10 Seasonal limit - Jul.
  11 Seasonal limit - Aug.
  12 Seasonal limit - Sep.
  13 Seasonal limit - Oct.
  14 Seasonal limit - Nov.
  15 Seasonal limit - Dec.
  999 Other


BluffL -- Bluff/Cliff/Escarpment

BluffL -- Bluff/Cliff/Escarpment

DB010 Bluff/Cliff/Escarpment
PFH Predominant Feature Height
  (29999) Unknown
SGC Gradient/Slope (percent)
  (0) Unknown


EmbankL -- Cut/Embankment/Fill Lines

EmbankL -- Cut/Embankment/Fill Lines

DB070 -- Cut

DB070 Cut
DEP Depth Below Surface Level
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
USE_/USE Usage
  (-32768) Null
VRR Vertical Reference Category
  (-32768) Null
WID Width (meters)
  (-32768) Null

DB090 -- Embankment/Fill Line

DB090 Embankment/Fill Line
DEP Depth Below Surface Level
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
USE_/USE Usage
  (0) Unknown
  8 Military
  69 Levee/Dike
  127 Levee/Dike as a Causeway
  136 Levee/Dike as a Fill
  999 Other
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not Cover (At High Water)
  8 Covers and Uncovers
  9 Not Applicable
WID Width (meters)
  (-32768) Null


LandfrmL -- Crevice/Crevasse/Fault Line

LandfrmL -- Crevice/Crevasse/Fault Line

DB060 -- Crevice/Crevasse

DB060 Crevice/Crevasse
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null

DB110 -- Fault Line

DB110 Fault Line
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


MtnP -- Cave

MtnP -- Cave

DB030 Cave
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


ThermalP -- Geothermal Feature/Volcano

ThermalP -- Geothermal Feature/Volcano

DB115 -- Geothermal Feature

DB115 Geothermal Feature
HGT Height Above Surface Level (meters)
  (-32768) Null
LOC Location Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SWT Well/Spring Type
  (0) Unknown
  1 Geyser
  2 Hot Spring
  3 Fumarole
VGT Volcanic Geologic Type
  (-32768) Null

DB180 -- Volcano

DB180 Volcano
HGT Height Above Surface Level (meters)
  (29999) Unknown
LOC Location Category
  0 Unknown
  (8) On Ground Surface
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SWT Well/Spring Type
  (-32768) Null
VGT Volcanic Geologic Type
  0 Unknown
  1 Volcano
  (2) Cinder Cone
  3 Shield
  4 Caldera
  5 Composite


BuildA -- Building

BuildA -- Building

AL015 -- Building

AL015 Building
ACC Accuracy Category
  (0) Unknown
  1 Accurate
  2 Approximate
  3 Doudtful
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
BFC Building Function Category
  (0) Unknown
  1 Fabrication Structures
  2 Government Building
  3 Capitol Building
  4 Castle
  5 Government Administration Building
  6 Hospital
  7 House of Worship
  8 Military Administration/Operations Building
  9 Museum
  10 Observatory
  11 Palace
  12 Police Station
  13 Prison
  14 Ranger Station
  15 School
  16 House
  17 Multi-Unit Dwelling
  18 Cemetery Building
  19 Farm Building
  20 Greenhouse
  21 Garage
  22 Watermill/Gristmill
  23 Wind Tunnel
  24 Warehouse
  25 Roundhouse
  26 R/R Storage/Repair Facility
  27 Depot Terminal
  28 Administration Building
  29 Aircraft Maintenance Shop
  30 Hangar
  31 Custom House
  33 Health Office
  35 Post Office
  36 Barracks/Dormitory
  37 Fire Station
  51 Market
  53 Bank
  54 Service/Refueling Station
  57 Restaurant
  59 R&D Lab/Research Facility
  60 University/College
  61 Courthouse
  66 Embassy
  69 Guard Shack/Guard Room
  70 Kennel
  77 Harbor Masters Office
  82 Lighthouse
  83 Power Generation
  85 Newspaper Plant
  86 Telephone Exchange (Main)
  87 Auditorium
  88 Opera House
  89 Processing/Treatment
  90 Pumphouse
  91 Mobile Home
  92 Weather Station
  93 Dependent's Housing/Bivouac Area
  95 Hotel
  96 Diplomatic Building
  98 Shed
  109 Senior citizen's Home
  116 Factory
  120 Automobile Plant
  151 Dormitory
  122 Shopping Center
  128 Library
  133 Commercial Building
  1001 Meeting Place
  1002 Polling Station
  1003 Executive Office
  1004 Ministerial Office
  1005 Human and Social Service Office
  1006 Correctional Institution
  999 Other
BNF Building Number of Floors
  (0) Unknown
BNK Bank Type Category
  (0) Unknown
  1001 Monetary Authority - Central Bank
  1002 Commercial Banking (Headquarters or Branch location)
  1003 Savings Institution
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FIT Factory Industry Type
  (0) Unknown
  311 Food Manufacturing
  312 Beverage, Ice, or Tobacco Product Manufacturing
  313 Textile Mills (fabric, fiber, yarn, and thread mills)
  314 Textile Product Mills (carpet, rug, curtain, drapery, linen, bag mills)
  315 Apparel Manufacturing
  316 Leather or Footwear Manufacturing
  321 Wood Product Manufacturing (except furniture)
  337 Furniture or Related Product Manufacturing
  322 Paper Manufacturing
  325 Chemical Manufacturing (solid, liquid, gas)
  326 Plastics or Rubber Products Manufacturing
  331 Primary Metal Manufacturing
  332 Fabricated Metal Product Manufacturing
  333 Machinery Manufacturing
  334 Computer or Electronic Product Manufacturing
  335 Electrical Equipment, Appliance, or Component Manufacturing
  336 Transportation Equipment Manufacturing
HGT Height Above Surface Level (meters)
  (29999) Unknown
HWT House of Worship Type
  (0) Unknown
  2 Cathedral
  3 Chapel
  4 Church
  5 Marabout
  6 Minaret
  7 Monastery/Covenent
  9 Mosque
  11 Pagoda
  14 Shrine
  15 Tabernacle
  16 Temple
  20 Synagogue
  21 Stupa
  998 Not Applicable
IDN Identification Number
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  2 Aluminum
  16 Clay
  21 Concrete
  45 Grass, Thatch
  62 Masonry (Brick/Stone)
  65 Mud
  83 Reinforced Concrete
  104 Soil
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  13 Chemical
  19 Coke
  64 Metal
  95 Sewage
  997 Not Applicable
  999 Other
SSR Structure Shape Roof
  (0) Unknown
  6 Conical/Peaked/NUM
  38 Curved/Round (Quonset)
  40 Dome
  41 Flat
  42 Gable (Pitched)
  47 Sawtooth
  50 With Monitor
  55 Flat with Monitor
  64 Gable with Monitor
  77 With Cupula
  78 With Turret
  79 With Tower
  999 Other
USE_/USE Usage
  (0) Unknown
  5 State
  6 Private
  8 Military
  22 Joint Military/Civilian
  23 International
  43 Institutional
  49 Civilian/Public
WID Width (meters)
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown

AL019 -- Shed

AL019 Shed
ACC Accuracy Category
  (-32768) Null
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
BFC Building Function Category
  (-32768) Null
BNF Building Number of Floors
  (0) Unknown
BNK Bank Type Category
  (-32768) Null
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FIT Factory Industry Type
  (0) Unknown
  311 Food Manufacturing
  312 Beverage, Ice, or Tobacco Product Manufacturing
  313 Textile Mills (fabric, fiber, yarn, and thread mills)
  314 Textile Product Mills (carpet, rug, curtain, drapery, linen, bag mills)
  315 Apparel Manufacturing
  316 Leather or Footwear Manufacturing
  321 Wood Product Manufacturing (except furniture)
  337 Furniture or Related Product Manufacturing
  322 Paper Manufacturing
  325 Chemical Manufacturing (solid, liquid, gas)
  326 Plastics or Rubber Products Manufacturing
  331 Primary Metal Manufacturing
  332 Fabricated Metal Product Manufacturing
  333 Machinery Manufacturing
  334 Computer or Electronic Product Manufacturing
  335 Electrical Equipment, Appliance, or Component Manufacturing
  336 Transportation Equipment Manufacturing
HGT Height Above Surface Level (meters)
  (29999) Unknown
HWT House of Worship Type
  (-32768) Null
IDN Identification Number
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
SSR Structure Shape Roof
  (-32768) Null
USE_/USE Usage
  (-32768) Null
WID Width (meters)
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown


BuiltupA -- Built-Up Area

BuiltupA -- Built-Up Area

AL020 Built-Up Area
BAC Built-up Area Classification
  (0) Unknown
  1 Sparse to Moderate
  2 Dense
EXS Existence Category
  0 Unknown
  7 Destroyed
  62 Partially Destroyed
  (999) Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NA2 Second Name
  (UNK) Unknown
USE_/USE Usage
  (0) Unknown
  26 Primary/1st Order
  30 Secondary/2nd Order
  31 Tertiary/3rd Order
  41 Industrial
  42 Commercial
  44 Residential
  111 Quartenary/4th Order
  128 Mixed Urban or built-up Land
  999 Other
  112 Quintary/5th Order


CommA -- Communication Building

CommA -- Communication Building

AT050 Communication Building
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  (0) Unknown
  12 Radio
  13 Radio Telephone
  15 TV
  16 Microwave
  33 Radio Telegraph
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public


LandmrkA -- Landmark Areas

LandmrkA -- Landmark Areas

AK030 -- Amusement Park

AK030 Amusement Park
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null

AK060 -- Campground/Campsite

AK060 Campground/Campsite
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null

AK070 -- Drive-In Theater

AK070 Drive-In Theater
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null

AK120 -- Park

AK120 Park
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null

AK160 -- Stadium/Amphitheater

AK160 Stadium/Amphitheater
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (29999) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null

AK180 -- Zoo/Safari Park

AK180 Zoo/Safari Park
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null

AL030 -- Cemetery

AL030 Cemetery
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (0) Unknown
  1 Buddhist
  2 Moslem
  4 Christian (undefined)
  5 Judiasm
  6 Greek Orthodox
  8 Shinto
  999 Other


MilA -- Military Areas

MilA -- Military Areas

AH010 -- Bastion

AH010 Bastion
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  40 Underground
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AH060 -- Underground Bunker

AH060 Underground Bunker
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  0 Unknown
  (4) Below Water Surface
  8 On Ground Surface
  40 Underground
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AL120 -- Missile Site

AL120 Missile Site
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  40 Underground
MST Missile Site Type
  (0) Unknown
  1 ABM
  2 ICBM
  3 IRBM
  4 SA1
  5 SA2
  6 SA3
  7 SA4
  8 SA5
  9 SA6
  10 SA7
  11 SA8
  12 SA9
  13 MRBM
  14 SSM
  15 SAM
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AT020 -- Early Warning Radar Site

AT020 Early Warning Radar Site
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  40 Underground
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AT045 -- Radar Transmitter

AT045 Radar Transmitter
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  40 Underground
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

FA015 -- Firing Range/Gunnery Range

FA015 Firing Range/Gunnery Range
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FRT Firing Range Type
  (0) Unknown
  1 Rifle/Small Arms
  2 Tank
  3 Artillery
  4 Grenade
  5 Demolition Area
  6 Impact Area
  999 Other
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

SU001 -- Military Base

SU001 Military Base
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU992 -- Restricted Area

SU992 Restricted Area
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU993 -- Cantonment Area

SU993 Cantonment Area
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU994 -- Landing Zone

SU994 Landing Zone
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU995 -- Dropzone

SU995 Dropzone
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU997 -- Manuever Area

SU997 Manuever Area
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU998 -- Training Site

SU998 Training Site
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU999 -- Installation Boundary

SU999 Installation Boundary
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null


MispopA -- Settlement Areas

MispopA -- Settlement Areas

AL012 -- Archeological Site

AL012 Archeological Site
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (-32768) Null
NAS Native Settlement Type
  (-32768) Null

AL105 -- Settlement

AL105 Settlement
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (0) Unknown
  2 Shantytown
  3 Tent Dwellings
NAS Native Settlement Type
  (-32768) Null

AL135 -- Native Settlement

AL135 Native Settlement
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (-32768) Null
NAS Native Settlement Type
  0 Unknown
  1 Centralized Habitation
  (2) Continuous Habitiation


MobileA -- Mobile Home Park

MobileA -- Mobile Home Park

AI020 Mobile Home Park
No attributes except metadata


PlazaA -- Plaza/City Square

PlazaA -- Plaza/City Square

AL170 Plaza/City Square
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


RuinsA -- Ruins

RuinsA -- Ruins

AL200 Ruins
HGT Height Above Surface Level (meters)
  (29999) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


SportA -- Sport Facilities

SportA -- Sport Facilities

AK040 -- Athletic Field

AK040 Athletic Field
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AK090 -- Fairgrounds

AK090 Fairgrounds
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AK100 -- Golf Course

AK100 Golf Course
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AK110 -- Grandstand

AK110 Grandstand
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AK130 -- Race Track

AK130 Race Track
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AK170 -- Swimming Pool

AK170 Swimming Pool
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


StationA -- Station

StationA -- Station

AQ125 Station
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  3 Railroad
  14 Bus
  40 Subway
  1002 Taxi


BuildL -- Building

BuildL -- Building

AL015 Building
ACC Accuracy Category
  (0) Unknown
  1 Accurate
  2 Approximate
  3 Doudtful
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
BFC Building Function Category
  (0) Unknown
  1 Fabrication Structures
  2 Government Building
  3 Capitol Building
  4 Castle
  5 Government Administration Building
  6 Hospital
  7 House of Worship
  8 Military Administration/Operations Building
  9 Museum
  10 Observatory
  11 Palace
  12 Police Station
  13 Prison
  14 Ranger Station
  15 School
  16 House
  17 Multi-Unit Dwelling
  18 Cemetery Building
  19 Farm Building
  20 Greenhouse
  21 Garage
  22 Watermill/Gristmill
  23 Wind Tunnel
  24 Warehouse
  25 Roundhouse
  26 R/R Storage/Repair Facility
  27 Depot Terminal
  28 Administration Building
  29 Aircraft Maintenance Shop
  30 Hangar
  31 Custom House
  33 Health Office
  35 Post Office
  36 Barracks/Dormitory
  37 Fire Station
  51 Market
  53 Bank
  54 Service/Refueling Station
  57 Restaurant
  59 R&D Lab/Research Facility
  60 University/College
  61 Courthouse
  66 Embassy
  69 Guard Shack/Guard Room
  70 Kennel
  77 Harbor Masters Office
  82 Lighthouse
  83 Power Generation
  85 Newspaper Plant
  86 Telephone Exchange (Main)
  87 Auditorium
  88 Opera House
  89 Processing/Treatment
  90 Pumphouse
  91 Mobile Home
  92 Weather Station
  93 Dependent's Housing/Bivouac Area
  95 Hotel
  96 Diplomatic Building
  98 Shed
  109 Senior citizen's Home
  116 Factory
  120 Automobile Plant
  151 Dormitory
  122 Shopping Center
  128 Library
  133 Commercial Building
  1001 Meeting Place
  1002 Polling Station
  1003 Executive Office
  1004 Ministerial Office
  1005 Human and Social Service Office
  1006 Correctional Institution
  999 Other
BNF Building Number of Floors
  (0) Unknown
BNK Bank Type Category
  (0) Unknown
  1001 Monetary Authority - Central Bank
  1002 Commercial Banking (Headquarters or Branch location)
  1003 Savings Institution
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FIT Factory Industry Type
  (0) Unknown
  311 Food Manufacturing
  312 Beverage, Ice, or Tobacco Product Manufacturing
  313 Textile Mills (fabric, fiber, yarn, and thread mills)
  314 Textile Product Mills (carpet, rug, curtain, drapery, linen, bag mills)
  315 Apparel Manufacturing
  316 Leather or Footwear Manufacturing
  321 Wood Product Manufacturing (except furniture)
  337 Furniture or Related Product Manufacturing
  322 Paper Manufacturing
  325 Chemical Manufacturing (solid, liquid, gas)
  326 Plastics or Rubber Products Manufacturing
  331 Primary Metal Manufacturing
  332 Fabricated Metal Product Manufacturing
  333 Machinery Manufacturing
  334 Computer or Electronic Product Manufacturing
  335 Electrical Equipment, Appliance, or Component Manufacturing
  336 Transportation Equipment Manufacturing
HGT Height Above Surface Level (meters)
  (29999) Unknown
HWT House of Worship Type
  (0) Unknown
  2 Cathedral
  3 Chapel
  4 Church
  5 Marabout
  6 Minaret
  7 Monastery/Covenent
  9 Mosque
  11 Pagoda
  14 Shrine
  15 Tabernacle
  16 Temple
  20 Synagogue
  21 Stupa
  998 Not Applicable
IDN Identification Number
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  2 Aluminum
  16 Clay
  21 Concrete
  45 Grass, Thatch
  62 Masonry (Brick/Stone)
  65 Mud
  83 Reinforced Concrete
  104 Soil
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  13 Chemical
  19 Coke
  64 Metal
  95 Sewage
  997 Not Applicable
  999 Other
SSR Structure Shape Roof
  (0) Unknown
  6 Conical/Peaked/NUM
  38 Curved/Round (Quonset)
  40 Dome
  41 Flat
  42 Gable (Pitched)
  47 Sawtooth
  50 With Monitor
  55 Flat with Monitor
  64 Gable with Monitor
  77 With Cupula
  78 With Turret
  79 With Tower
  999 Other
USE_/USE Usage
  (0) Unknown
  5 State
  6 Private
  8 Military
  22 Joint Military/Civilian
  23 International
  43 Institutional
  49 Civilian/Public
WID Width (meters)
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown


CommP -- Communication Sites

CommP -- Communication Sites

AT010 -- Disk/Dish

AT010 Disk/Dish
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public

AT050 -- Communication Building

AT050 Communication Building
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (-32768) Null
IDN Identification Number
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  (0) Unknown
  12 Radio
  13 Radio Telephone
  15 TV
  16 Microwave
  33 Radio Telegraph
  35 Radar Antenna
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public

AT080 -- Communication Tower

AT080 Communication Tower
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
IDN Identification Number
  (0) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
NST Navigation System Types
  (0) Unknown
  12 Radio
  13 Radio Telephone
  15 TV
  16 Microwave
  33 Radio Telegraph
  35 Radar Antenna
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public


LandmrkL -- Race Track/Ski Jump

LandmrkL -- Race Track/Ski Jump

AK130 -- Race Track

AK130 Race Track
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AK150 -- Ski Jump

AK150 Ski Jump
EXS Existence Category
  0 Unknown
  (1) Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


BuildP -- Building/Shed

BuildP -- Building/Shed

AL015 -- Building

AL015 Building
AOO Angle of Orientation (degrees)
  (999) Unknown
BFC Building Function Category
  (0) Unknown
  1 Fabrication Structures
  2 Government Building
  3 Capitol Building
  4 Castle
  5 Government Administration Building
  6 Hospital
  7 House of Worship
  8 Military Administration/Operations Building
  9 Museum
  10 Observatory
  11 Palace
  12 Police Station
  13 Prison
  14 Ranger Station
  15 School
  16 House
  17 Multi-Unit Dwelling
  18 Cemetery Building
  19 Farm Building
  20 Greenhouse
  21 Garage
  22 Watermill/Gristmill
  23 Wind Tunnel
  24 Warehouse
  25 Roundhouse
  26 R/R Storage/Repair Facility
  27 Depot Terminal
  28 Administration Building
  29 Aircraft Maintenance Shop
  30 Hangar
  31 Custom House
  33 Health Office
  35 Post Office
  36 Barracks/Dormitory
  37 Fire Station
  51 Market
  53 Bank
  54 Service/Refueling Station
  57 Restaurant
  59 R&D Lab/Research Facility
  60 University/College
  61 Courthouse
  66 Embassy
  69 Guard Shack/Guard Room
  70 Kennel
  77 Harbor Masters Office
  82 Lighthouse
  83 Power Generation
  85 Newspaper Plant
  86 Telephone Exchange (Main)
  87 Auditorium
  88 Opera House
  89 Processing/Treatment
  90 Pumphouse
  91 Mobile Home
  92 Weather Station
  93 Dependent's Housing/Bivouac Area
  95 Hotel
  96 Diplomatic Building
  98 Shed
  109 Senior citizen's Home
  116 Factory
  120 Automobile Plant
  151 Dormitory
  122 Shopping Center
  128 Library
  133 Commercial Building
  1001 Meeting Place
  1002 Polling Station
  1003 Executive Office
  1004 Ministerial Office
  1005 Human and Social Service Office
  1006 Correctional Institution
  999 Other
BNF Building Number of Floors
  (0) Unknown
BNK Bank Type Category
  (0) Unknown
  1001 Monetary Authority - Central Bank
  1002 Commercial Banking (Headquarters or Branch location)
  1003 Savings Institution
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FIT Factory Industry Type
  (0) Unknown
  311 Food Manufacturing
  312 Beverage, Ice, or Tobacco Product Manufacturing
  313 Textile Mills (fabric, fiber, yarn, and thread mills)
  314 Textile Product Mills (carpet, rug, curtain, drapery, linen, bag mills)
  315 Apparel Manufacturing
  316 Leather or Footwear Manufacturing
  321 Wood Product Manufacturing (except furniture)
  337 Furniture or Related Product Manufacturing
  322 Paper Manufacturing
  325 Chemical Manufacturing (solid, liquid, gas)
  326 Plastics or Rubber Products Manufacturing
  331 Primary Metal Manufacturing
  332 Fabricated Metal Product Manufacturing
  333 Machinery Manufacturing
  334 Computer or Electronic Product Manufacturing
  335 Electrical Equipment, Appliance, or Component Manufacturing
  336 Transportation Equipment Manufacturing
HGT Height Above Surface Level (meters)
  (29999) Unknown
HWT House of Worship Type
  (0) Unknown
  2 Cathedral
  3 Chapel
  4 Church
  5 Marabout
  6 Minaret
  7 Monastery/Covenent
  9 Mosque
  11 Pagoda
  14 Shrine
  15 Tabernacle
  16 Temple
  20 Synagogue
  21 Stupa
  998 Not Applicable
LEN_/LEN Length/Diameter
  (-32768) Null
LMC Landmark Category
  (0) Unknown
  1 Landmark
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (0) Unknown
  13 Chemical
  19 Coke
  64 Metal
  95 Sewage
  997 Not Applicable
  999 Other
ZV2 Highest Z-value (meters)
  (29999) Unknown

AL019 -- Shed

AL019 Shed
AOO Angle of Orientation (degrees)
  (999) Unknown
BFC Building Function Category
  (-32768) Null
BNF Building Number of Floors
  (-32768) Null
BNK Bank Type Category
  (-32768) Null
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
FIT Factory Industry Type
  (0) Unknown
  311 Food Manufacturing
  312 Beverage, Ice, or Tobacco Product Manufacturing
  313 Textile Mills (fabric, fiber, yarn, and thread mills)
  314 Textile Product Mills (carpet, rug, curtain, drapery, linen, bag mills)
  315 Apparel Manufacturing
  316 Leather or Footwear Manufacturing
  321 Wood Product Manufacturing (except furniture)
  337 Furniture or Related Product Manufacturing
  322 Paper Manufacturing
  325 Chemical Manufacturing (solid, liquid, gas)
  326 Plastics or Rubber Products Manufacturing
  331 Primary Metal Manufacturing
  332 Fabricated Metal Product Manufacturing
  333 Machinery Manufacturing
  334 Computer or Electronic Product Manufacturing
  335 Electrical Equipment, Appliance, or Component Manufacturing
  336 Transportation Equipment Manufacturing
HGT Height Above Surface Level (meters)
  (29999) Unknown
HWT House of Worship Type
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
LMC Landmark Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PRO Product Category
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown


BuiltupP -- Built-Up Area

BuiltupP -- Built-Up Area

AL020 Built-Up Area
No attributes except metadata


FortP -- Fortification

FortP -- Fortification

AH050 FortificationPoint
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other


LandmrkP -- Landmark Points

LandmrkP -- Landmark Points

AK020 -- Amusement Park Attraction

AK020 Amusement Park Attraction
COC Conspicuous Category
  (-32768) Null
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null
SSC Structure Shape Category
  (0) Unknown
  17 Spherical (Hemispherical)
  21 Artificial Mountain
  23 Ferris Wheel
  25 Roller Coaster
  999 Other
TXT Text Attribute
  (N/A) Null
WID Width (meters)
  (-32768) Null

AK060 -- Campground/Campsite

AK060 Campground/Campsite
COC Conspicuous Category
  (-32768) Null
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (N/A) Null
NFN Name Identifier
  (N/A) Null
REL Religious Denomination
  (-32768) Null
SSC Structure Shape Category
  (-32768) Null
TXT Text Attribute
  (UNK) Unknown
WID Width (meters)
  (-32768) Null

AK150 -- Ski Jump

AK150 Ski Jump
COC Conspicuous Category
  (-32768) Null
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null
SSC Structure Shape Category
  (-32768) Null
TXT Text Attribute
  (N/A) Null
WID Width (meters)
  (-32768) Null

AL030 -- Cemetery

AL030 Cemetery
COC Conspicuous Category
  (0) Unknown
  1 Conspicuous from sea
  6 Inconspicuous
EXS Existence Category
  (0) Unknown
  30 Not Isolated
  31 Isolated
HGT Height Above Surface Level (meters)
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (0) Unknown
  1 Buddhist
  2 Moslem
  4 Christian (undefined)
  5 Judiasm
SSC Structure Shape Category
  (-32768) Null
TXT Text Attribute
  (N/A) Null
WID Width (meters)
  (-32768) Null

AL130 -- Monument

AL130 Monument
COC Conspicuous Category
  (0) Unknown
  1 Conspicuous from sea
  6 Inconspicuous
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
REL Religious Denomination
  (-32768) Null
SSC Structure Shape Category
  (0) Unknown
  12 Pyramid
  77 Arch
  109 Obelisk
  999 Other
TXT Text Attribute
  (N/A) Null
WID Width (meters)
  (-32768) Null


ManholeP -- Manhole Cover

ManholeP -- Manhole Cover

AQ115 Manhole Cover
ACC Accuracy Category
  (0) Unknown
  1 Accurate
  2 Approximate
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
  999 Other
MCC Material Composition Category
  (0) Unknown
  2 Aluminum
  51 Iron
  64 Metal
  72 Part Metal
  107 Steel
  117 Wood
  999 Other
TXT Text Attribute
  (UNK) Unknown


MilP -- Military Sites

MilP -- Military Sites

AH010 -- Bastion

AH010 Bastion
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AH060 -- Underground Bunker

AH060 Underground Bunker
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  0 Unknown
  (4) Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AL120 -- Missile Site

AL120 Missile Site
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
MST Missile Site Type
  (0) Unknown
  1 ABM
  2 ICBM
  3 IRBM
  4 SA1
  5 SA2
  6 SA3
  7 SA4
  8 SA5
  9 SA6
  10 SA7
  11 SA8
  12 SA9
  13 MRBM
  14 SSM
  15 SAM
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AT020 -- Early Warning Radar Site

AT020 Early Warning Radar Site
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

AT045 -- Radar Transmitter

AT045 Radar Transmitter
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

FA015 -- Firing Range/Gunnery Range

FA015 Firing Range/Gunnery Range
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  11 Temporary
  (28) Operational
FRT Firing Range Type
  (0) Unknown
  1 Rifle/Small Arms
  2 Tank
  3 Artillery
  4 Grenade
  5 Demolition Area
  6 Impact Area
  999 Other
LOC Location Category
  (0) Unknown
  4 Below Water Surface
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (0) Unknown
  1 Air Force
  2 Army
  3 Coast Guard
  4 Marines
  5 Navy
  7 Joint
  999 Other

SU001 -- Military Base

SU001 Military Base
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU884 -- Training Site

SU884 Training Site
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU885 -- Refueling Site

SU885 Refueling Site
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU886 -- Farp Site

SU886 Farp Site
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU887 -- Ammo

SU887 Ammo
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null

SU888 -- Observation Point

SU888 Observation Point
EXS Existence Category
  (-32768) Null
FRT Firing Range Type
  (-32768) Null
LOC Location Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
MST Missile Site Type
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
YSU Service Branch
  (-32768) Null


MispopP -- Miscellanous Population Features

MispopP -- Miscellanous Population Features

AL012 -- Archeological Site

AL012 Archeological Site
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (-32768) Null

AL100 -- Hut

AL100 Hut
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (-32768) Null

AL105 -- Settlement

AL105 Settlement
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (0) Unknown
  3 Tent Dwellings

AL135 -- Native Settlement

AL135 Native Settlement
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (0) Unknown
  3 Tent Dwellings

AL250 -- Underground Dwelling

AL250 Underground Dwelling
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPT Populated Place Type
  (-32768) Null


PopP -- General Miscellaneous Feature

PopP -- General Miscellaneous Feature

ZD019 General Miscellaneous Feature
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TXT Text Attribute
  (UNK) Unknown
ZV2 Highest Z-value (meters)
  (-32768) Null


RuinsP -- Ruins

RuinsP -- Ruins

AL200 Ruins
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (29999) Unknown
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  0 Unknown
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
WID Width (meters)
  (-32768) Null


StationP -- Station

StationP -- Station

AQ125 Station
GTC Gate Type Category
  1 Tollgate
  (99) Other
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  3 Railroad
  14 Bus
  40 Subway


AerofacA -- Aeronautical Facilities

AerofacA -- Aeronautical Facilities

GB005 -- Airport/Airfield

GB005 Airport/Airfield
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Information Known
  2 Limits and Information Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  23 International
  49 Civilian/Public
ZV2 Highest Z-value (meters)
  (29999) Unknown

GB030 -- Helicopter Landing Pad

GB030 Helicopter Landing Pad
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Information Known
  2 Limits and Information Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  23 International
  49 Civilian/Public
ZV2 Highest Z-value (meters)
  (29999) Unknown

GB035 -- Heliport

GB035 Heliport
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Information Known
  2 Limits and Information Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  23 International
  49 Civilian/Public
ZV2 Highest Z-value (meters)
  (29999) Unknown

GB050 -- Revetment Area

GB050 Revetment Area
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Information Known
  2 Limits and Information Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  23 International
  49 Civilian/Public
ZV2 Highest Z-value (meters)
  (29999) Unknown


AirspaceA -- Airspace

AirspaceA -- Airspace

GA005 -- Airspace

GA005 Airspace
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational

GA015 -- Special Use Airspace

GA015 Special Use Airspace
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational


BridgeA -- Bridge/Overpass/Viaduct

BridgeA -- Bridge/Overpass/Viaduct

AQ040 Bridge/Overpass/Viaduct
BCC Bypass Condition Category
  (0) Unknown
  1 Easy (Obstacle can be crossed within 2 KM of feature, no work)
  2 Difficult (Obstacle can be crossed within 2 KM of feature, work required)
  3 Impossible (Obstacle cannot be bypassed within 2 KM of feature)
BSC Bridge/Bridge Superstructure Category
  (0) Unknown
  2 Cantilever
  7 Tower Suspension
  8 Truss
  17 Arch Suspension
BSM Bridge Span Mobility
  (0) Unknown
  1 Moveable Span
  2 Fixed Span
  997 Unpopulated
  998 Not Applicable
  999 Other
EXS Existence Category
  0 Unknown
  (1) Definite
  2 Doubtful
  3 Reported
  5 Under Construction
  7 Destroyed
  28 Operational
LC1 Load Class Type 1 - One-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC2 Load Class Type 2 - Two-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC3 Load Class Type 3 - One-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LC4 Load Class Type 4 - Two-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
MCC Material Composition Category
  (0) Unknown
  21 Concrete
  62 Masonry (Brick/Stone)
  77 Prestressed Concrete
  83 Reinforced Concrete
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (0) MinValue
  32768 MaxValue
SHC Safe Horizontal Clearance
  (0) MinValue
  32768 MaxValue
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown


InterA -- Interchange

InterA -- Interchange

AP020 Interchange
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
LOC Location Category
  0 Unknown
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
LTN Lane/Track Number
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RIT Road Interchange Type
  (0) Unknown
  1 Cloverleaf
  2 Diamond
  999 Other
RST Road/Runway Surface Type
  0 Unknown
  (1) Hard/Paved
  2 Loose/Unpaved
  3 Loose/Light
RTN Route Name
  (UNK) Unknown
TUC Transportation Use Category
  0 Unknown
  (4) Road
  6 Streets
  7 Through Route
  1001 Tank Trail
  1003 Traffic Circle on a Through Route
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  6 Private
  23 International
  37 Interstate
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown
WTC Weather Type Category
  0 Unknown
  (1) All Weather
  2 Fair/Dry Weather
  3 Winter Only


LandingA -- Landing Place

LandingA -- Landing Place

BB150 Landing Place
COD Certainty of Delineation
  (1) Limits and Info Known
  2 Limits and Info Unknown
EXS Existence Category
  (45) Natural


LightHouseA -- Lighthouse

LightHouseA -- Lighthouse

BC050 Lighthouse
AOO Angle of Orientation (degrees)
  (999) Unknown
COC Conspicuous Category
  (0) Unknown
  1 Conspicuous from sea
  6 Inconspicuous
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  5 Under Construction
  (28) Operational
HGT Height Above Surface Level (meters)
  (29999) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown


LoadingA -- Offshore Loading Facility

LoadingA -- Offshore Loading Facility

BB170 Offshore Loading Facility
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


PierA -- Pier/Wharf/Quay

PierA -- Pier/Wharf/Quay

BB190 Pier/Wharf/Quay
LOC Location Category
  (0) Unknown
  15 On Water Surface/Floating
  30 Non-Floating
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public


RampA -- Slipway/Patent Slip Area

RampA -- Slipway/Patent Slip Area

BB240 Slipway/Patent Slip Area
LEN_/LEN Length/Diameter
  (-32768) Null
LOC Location Category
  (-32768) Null
MAC Maritime Area Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
WID Width (meters)
  (-32768) Null


RestA -- Vehicle Stopping Area/Rest Area

RestA -- Vehicle Stopping Area/Rest Area

AQ135 Vehicle Stopping Area/Rest Area
WID Width (meters)
  (-32768) Null


RouteA -- Route

RouteA -- Route

GA045 Route
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


RryardA -- Railroad Yard Areas

RryardA -- Railroad Yard Areas

AN060 -- Railroad Yard/Marshalling Yard

AN060 Railroad Yard/Marshalling Yard
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

AN075 -- Railroad Turntable

AN075 Railroad Turntable
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


RunwayA -- Runway Areas

RunwayA -- Runway Areas

GB015 -- Apron/Hardstand

GB015 Apron/Hardstand
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
COD Certainty of Delineation
  (-32768) Null
EXS Existence Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (-32768) Null
USE_/USE Usage
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null

GB045 -- Overrun/Stopway

GB045 Overrun/Stopway
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
COD Certainty of Delineation
  (-32768) Null
EXS Existence Category
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (-32768) Null
USE_/USE Usage
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null

GB055 -- Runway

GB055 Runway
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
COD Certainty of Delineation
  (-32768) Null
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  5 Asphault
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (0) Unknown
  5 Grass/Sod (soft)
  7 Permanent
  8 Temporary
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  23 International
  49 Civilian/Public
ZV2 Highest Z-value (meters)
  (29999) Unknown

GB075 -- Taxiway

GB075 Taxiway
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
COD Certainty of Delineation
  (-32768) Null
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (-32768) Null
USE_/USE Usage
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null


TeethA -- Dragon Teeth

TeethA -- Dragon Teeth

AL060 Dragon Teeth
No attributes except metadata


TunnelA -- Tunnel

TunnelA -- Tunnel

AQ130 Tunnel
BCC Bypass Condition Category
  (-32768) Null
BSC Bridge/Bridge Superstructure Category
  (-32768) Null
BSM Bridge Span Mobility
  (-32768) Null
EXS Existence Category
  0 Unknown
  1 Definite
  2 Doubtful
  3 Reported
  5 Under Construction
  7 Destroyed
  (28) Operational
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (-32768) Null
SHC Safe Horizontal Clearance
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null


BridgeL -- Bridge Lines

BridgeL -- Bridge Lines

AQ040 -- Bridge/Overpass/Viaduct

AQ040 Bridge/Overpass/Viaduct
BCC Bypass Condition Category
  (0) Unknown
  1 Easy (Obstacle can be crossed within 2 KM of feature, no work)
  2 Difficult (Obstacle can be crossed within 2 KM of feature, work required)
  3 Impossible (Obstacle cannot be bypassed within 2 KM of feature)
BSC Bridge/Bridge Superstructure Category
  (0) Unknown
  2 Cantilever
  7 Tower Suspension
  8 Truss
  17 Arch Suspension
BSM Bridge Span Mobility
  (0) Unknown
  1 Moveable Span
  2 Fixed Span
  997 Unpopulated
  998 Not Applicable
  999 Other
EXS Existence Category
  0 Unknown
  (1) Definite
  2 Doubtful
  3 Reported
  5 Under Construction
  7 Destroyed
  28 Operational
LC1 Load Class Type 1 - One-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC2 Load Class Type 2 - Two-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC3 Load Class Type 3 - One-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LC4 Load Class Type 4 - Two-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  21 Concrete
  62 Masonry (Brick/Stone)
  77 Prestressed Concrete
  83 Reinforced Concrete
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (0) MinValue
  32768 MaxValue
SHC Safe Horizontal Clearance
  (0) MinValue
  32768 MaxValue
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AQ111 -- Prepared Raft/Float Bridge

AQ111 Prepared Raft/Float Bridge
BCC Bypass Condition Category
  (-32768) Null
BSC Bridge/Bridge Superstructure Category
  (-32768) Null
BSM Bridge Span Mobility
  (-32768) Null
EXS Existence Category
  (-32768) Null
LC1 Load Class Type 1 - One-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC2 Load Class Type 2 - Two-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC3 Load Class Type 3 - One-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LC4 Load Class Type 4 - Two-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (-32768) Null
SHC Safe Horizontal Clearance
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null


CausewayL -- Causeway

CausewayL -- Causeway

AQ064 Causeway
TUC Transportation Use Category
  0 Unknown
  1 Both Road and Railroad
  3 Railroad
  (4) Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown


FerryL -- Ferry Crossing

FerryL -- Ferry Crossing

AQ070 Ferry Crossing
EXS Existence Category
  0 Unknown
  (28) Operational
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian


FordL -- Ford

FordL -- Ford

BH070 Ford
No attributes except metadata


InterL -- Interchange

InterL -- Interchange

AP020 Interchange
ACC Accuracy Category
  (-32768) Null
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
LOC Location Category
  0 Unknown
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
LTN Lane/Track Number
  (0) Unknown
MED Median Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (0) Unknown
  1 Hard/Paved
  2 Loose/Unpaved
  3 Loose/Light
RTN Route Name
  (UNK) Unknown
RTT Route Intended Use
  (-32768) Null
TUC Transportation Use Category
  0 Unknown
  (4) Road
  6 Streets
  7 Through Route
  1001 Tank Trail
  1003 Traffic Circle on a Through Route
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  6 Private
  23 International
  37 Interstate
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown
WTC Weather Type Category
  0 Unknown
  (1) All Weather
  2 Fair/Dry Weather
  3 Winter Only


LiftL -- Aerial Cable/Ski Lift

LiftL -- Aerial Cable/Ski Lift

AQ010 Aerial Cable/Ski Lift
HGT Height Above Surface Level (meters)
  (0) MinValue
  29999 MaxValue
USE_/USE Usage
  (0) Unknown
  120 Recreational
  130 Transportation
  999 Other
ZV2 Highest Z-value (meters)
  (29999) Unknown


PierL -- Pier/Wharf/Quay

PierL -- Pier/Wharf/Quay

BB190 Pier/Wharf/Quay
LEN_/LEN Length/Diameter
  (-32768) Null
WID Width (meters)
  (0) MinValue
  19 MaxValue


RailrdL -- Railroad Lines

RailrdL -- Railroad Lines

AN010 -- Railroad/Railway

AN010 Railroad/Railway
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  8 Dismantled
  (28) Operational
FCO Feature Configuration
  0 Unknown
  2 Mulitple
  (3) Single
  11 Double
  12 Juxtaposition
GAW Gauge Width (centimeters)
  (0) Unknown
LOC Location Category
  0 Unknown
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
LTN Lane/Track Number
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RGC Railroad Gauge Category
  0 Unknown
  1 Broad Guage
  2 Narrow/NarrowGauge
  (3) Normal (Country Specific)
RRA Railroad Power Source
  0 Unknown
  1 Electrified Track
  3 Overhead Electrified
  (4) Non-Electrified
RRC Railroad Category
  0 Unknown
  2 Car-Line
  3 Monorail
  8 Logging
  13 Marine Railroad
  14 Tramway
  15 Inclined Railroad
  (16) Main Line
  21 Railroad in Road
  999 Other
RSA Railroad Siding Attribute
  (-32768) Null

AN050 -- Railroad Siding/Railroad Spur

AN050 Railroad Siding/Railroad Spur
ACC Accuracy Category
  (-32768) Null
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  8 Dismantled
  (28) Operational
FCO Feature Configuration
  (-32768) Null
GAW Gauge Width (centimeters)
  (-32768) Null
LOC Location Category
  (-32768) Null
LTN Lane/Track Number
  (0) Unknown
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RGC Railroad Gauge Category
  0 Unknown
  1 Broad Guage
  2 Narrow/NarrowGauge
  (3) Normal (Country Specific)
RRA Railroad Power Source
  0 Unknown
  1 Electrified Track
  3 Overhead Electrified
  (4) Non-Electrified
RRC Railroad Category
  (-32768) Null
RSA Railroad Siding Attribute
  (0) Unknown
  1 Spur
  2 Siding
  3 Passing

SU002 -- Subway

SU002 Subway
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  8 Dismantled
  (28) Operational
FCO Feature Configuration
  0 Unknown
  2 Mulitple
  (3) Single
  11 Double
  12 Juxtaposition
GAW Gauge Width (centimeters)
  (0) Unknown
LOC Location Category
  0 Unknown
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  (40) Underground
LTN Lane/Track Number
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RGC Railroad Gauge Category
  0 Unknown
  1 Broad Guage
  2 Narrow/NarrowGauge
  (3) Normal (Country Specific)
RRA Railroad Power Source
  0 Unknown
  1 Electrified Track
  3 Overhead Electrified
  (4) Non-Electrified
RRC Railroad Category
  0 Unknown
  2 Car-Line
  3 Monorail
  8 Logging
  13 Marine Railroad
  14 Tramway
  15 Inclined Railroad
  (16) Main Line
  21 Railroad in Road
  999 Other
RSA Railroad Siding Attribute
  (-32768) Null


RampL -- Slipway/Patent Slip Area

RampL -- Slipway/Patent Slip Area

BB240 Slipway/Patent Slip Area
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
WID Width (meters)
  (-32768) Null


RevetmentL -- Revetment Line

RevetmentL -- Revetment Line

GB050 Revetment Line
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  5 Asphault
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
RST Road/Runway Surface Type
  (0) Unknown
  1 Hard/Paved
  2 Loose/Unpaved
  3 Loose/Light
ZV2 Highest Z-value (meters)
  (29999) Unknown


RoadL -- Road

RoadL -- Road

AP030 Road
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
LOC Location Category
  0 Unknown
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
LTN Lane/Track Number
  (0) Unknown
MED Median Category
  0 Unknown
  1 With Median
  (2) Without Median
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (0) Unknown
  1 Hard/Paved
  2 Loose/Unpaved
  3 Loose/Light
RTN Route Name
  (UNK) Unknown
RTT Route Intended Use
  (0) Unknown
  14 Primary Route
  15 Secondary Route
  16 Limited Access Route (e.g. Motorway/Autobahn/Interstate)
TUC Transportation Use Category
  0 Unknown
  (4) Road
  6 Streets
  7 Through Route
  1001 Tank Trail
  1003 Traffic Circle on a Through Route
USE_/USE Usage
  (0) Unknown
  4 National
  5 State
  6 Private
  23 International
  37 Interstate
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown
WTC Weather Type Category
  0 Unknown
  (1) All Weather
  2 Fair/Dry Weather
  3 Winter Only


RouteL -- Route/Complex Term Route

RouteL -- Route/Complex Term Route

GA045 -- Route

GA045 Route
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

GA047 -- Complex Term Route

GA047 Complex Term Route
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


RunwayL -- Runway

RunwayL -- Runway

GB055 Runway
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  5 Asphault
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
RST Road/Runway Surface Type
  (0) Unknown
  1 Hard/Paved
  2 Loose/Unpaved
  3 Loose/Light
ZV2 Highest Z-value (meters)
  (29999) Unknown


ShedL -- Snow/Rock Shed

ShedL -- Snow/Rock Shed

AL210 Snow/Rock Shed
USE_/USE Usage
  0 Unknown
  (115) Snow Shed
  116 Rock Shed


TeethL -- Dragon Teeth

TeethL -- Dragon Teeth

AL060 Dragon Teeth
WID Width (meters)
  (-32768) Null


TrackL -- Cart Track

TrackL -- Cart Track

AP010 Cart Track
WTC Weather Type Category
  0 Unknown
  (2) Fair/Dry Weather
  3 Winter Only


TrailL -- Trail

TrailL -- Trail

AP050 Trail
WTC Weather Type Category
  0 Unknown
  (2) Fair/Dry Weather
  3 Winter Only


TransL -- Gate/Barrier

TransL -- Gate/Barrier

AP040 -- Gate

AP040 Gate
TUC Transportation Use Category
  0 Unknown
  1 Both Road and Railroad
  3 Railroad
  (4) Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AP041 -- Barrier

AP041 Barrier
TUC Transportation Use Category
  0 Unknown
  1 Both Road and Railroad
  3 Railroad
  (4) Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown


TunnelL -- Tunnel

TunnelL -- Tunnel

AQ130 Tunnel
BCC Bypass Condition Category
  (0) Unknown
  1 Easy (Obstacle can be crossed within 2 KM of feature, no work)
  2 Difficult (Obstacle can be crossed within 2 KM of feature, work required)
  3 Impossible (Obstacle cannot be bypassed within 2 KM of feature)
EXS Existence Category
  0 Unknown
  (1) Definite
  2 Doubtful
  3 Reported
  5 Under Construction
  7 Destroyed
  28 Operational
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (0) MinValue
  32768 MaxValue
SHC Safe Horizontal Clearance
  (0) MinValue
  32768 MaxValue
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown


AerofacP -- Aeronautical Facilities

AerofacP -- Aeronautical Facilities

GB005 -- Airport/Airfield

GB005 Airport/Airfield
APT Airfield Type
  (0) Unknown
  1 Major Airport
  4 Seaplane Base
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Info Known
  2 Limits and Info Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MCC Material Composition Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
  998 Sea Plane Landing Area
ZV2 Highest Z-value (meters)
  (29999) Unknown

GB030 -- Helicopter Landing Pad

GB030 Helicopter Landing Pad
APT Airfield Type
  (-32768) Null
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Info Known
  2 Limits and Info Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null

GB035 -- Heliport

GB035 Heliport
APT Airfield Type
  (-32768) Null
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Info Known
  2 Limits and Info Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MCC Material Composition Category
  (0) Unknown
  8 Boulders
  9 Brick
  21 Concrete
  30 Earthen
  62 Masonry (Brick/Stone)
  83 Reinforced Concrete
  117 Wood
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
  998 Sea Plane Landing Area
ZV2 Highest Z-value (meters)
  (-32768) Null

GB047 -- Airport RP Coordinate

GB047 Airport RP Coordinate
APT Airfield Type
  (0) Unknown
  1 Major Airport
  4 Seaplane Base
COD Certainty of Delineation
  0 Unknown
  (1) Limits and Info Known
  2 Limits and Info Unknown
EXS Existence Category
  0 Unknown
  6 Abandoned/Disused
  (28) Operational
MCC Material Composition Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  8 Military
  22 Joint Military/Civilian
  49 Civilian/Public
  998 Sea Plane Landing Area
ZV2 Highest Z-value (meters)
  (-32768) Null


BridgeP -- Bridge Points

BridgeP -- Bridge Points

AQ040 -- Bridge/Overpass/Viaduct

AQ040 Bridge/Overpass/Viaduct
BSC Bridge/Bridge Superstructure Category
  (0) Unknown
  2 Cantilever
  7 Tower Suspension
  8 Truss
  17 Arch Suspension
BSM Bridge Span Mobility
  (0) Unknown
  1 Moveable Span
  2 Fixed Span
  997 Unpopulated
  998 Not Applicable
  999 Other
EXS Existence Category
  0 Unknown
  1 Definite
  2 Doubtful
  3 Reported
  5 Under Construction
  7 Destroyed
  (28) Operational
LC1 Load Class Type 1 - One-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC2 Load Class Type 2 - Two-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC3 Load Class Type 3 - One-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LC4 Load Class Type 4 - Two-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  21 Concrete
  62 Masonry (Brick/Stone)
  77 Prestressed Concrete
  83 Reinforced Concrete
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (0) Unknown
SHC Safe Horizontal Clearance
  (0) Unknown
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AQ045 -- Bridge Span

AQ045 Bridge Span
BSC Bridge/Bridge Superstructure Category
  (-32768) Null
BSM Bridge Span Mobility
  (-32768) Null
EXS Existence Category
  (-32768) Null
LC1 Load Class Type 1 - One-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC2 Load Class Type 2 - Two-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC3 Load Class Type 3 - One-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LC4 Load Class Type 4 - Two-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (0) Unknown
  21 Concrete
  62 Masonry (Brick/Stone)
  77 Prestressed Concrete
  83 Reinforced Concrete
  107 Steel
  117 Wood
  999 Other
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (-32768) Null
SHC Safe Horizontal Clearance
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null

AQ111 -- Prepared Raft/Float Bridge

AQ111 Prepared Raft/Float Bridge
BSC Bridge/Bridge Superstructure Category
  (-32768) Null
BSM Bridge Span Mobility
  (-32768) Null
EXS Existence Category
  (-32768) Null
LC1 Load Class Type 1 - One-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC2 Load Class Type 2 - Two-Way Wheeled (tons)
  (0) MinValue
  200 MaxValue
LC3 Load Class Type 3 - One-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LC4 Load Class Type 4 - Two-Way Tracked (tons)
  (0) MinValue
  200 MaxValue
LEN_/LEN Length/Diameter
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (-32768) Null
SHC Safe Horizontal Clearance
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null


CulvertP -- Culvert

CulvertP -- Culvert

AQ065 Culvert
WID Width (meters)
  (-32768) Null


FerryP -- Ferry Crossing

FerryP -- Ferry Crossing

AQ070 Ferry Crossing
EXS Existence Category
  0 Unknown
  (28) Operational
FCL Ferry Crossing Length
  (0) Unknown
FER Ferry Type
  (0) Unknown
  1 With Cables/Chains
  2 Without cables/Chains
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian


FordP -- Ford

FordP -- Ford

BH070 Ford
LEN_/LEN Length/Diameter
  (-32768) Null


HarborP -- Anchorage/Anchor

HarborP -- Anchorage/Anchor

BB010 -- Anchorage

BB010 Anchorage
MAC Maritime Area Category
  (0) Unknown
  53 Seaplane Anchorage
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

BB019 -- Anchor

BB019 Anchor
MAC Maritime Area Category
  (-32768) -32768
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


InterP -- Interchange

InterP -- Interchange

AP020 InterchangePoint
LOC Location Category
  (0) Unknown
  8 On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
RIT Road Interchange Type
  (0) Unknown
  1 Cloverleaf
  2 Diamond
  999 Other
USE_/USE Usage
  (0) Unknown
  4 National
  23 International
  50 Limited


LighthouseP -- Lighthouse

LighthouseP -- Lighthouse

BC050 Lighthouse
ATN Aids to Navigation
  (0) Unknown
  1 Marked
  2 Unmarked
  3 Lit
  4 Unlit
  999 Other
EXS Existence Category
  (0) Unknown
  6 Abandoned/Disused
  5 Under Construction
  28 Operational
LCN Light Characteristic Number
  (0) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PER Period of Light
  (0) Unknown


MisaeroP -- Miscellaneous Aeronautical Features

MisaeroP -- Miscellaneous Aeronautical Features

AQ060 -- Control Tower

AQ060 Control Tower
EXS Existence Category
  0 Unknown
  (1) Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (0) MinValue
  29999 MaxValue
LFA Light Function Aeronautical
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown

AQ110 -- Mooring Mast

AQ110 Mooring Mast
EXS Existence Category
  0 Unknown
  (1) Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (0) MinValue
  29999 MaxValue
LFA Light Function Aeronautical
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown

GB010 -- Airport Lighting

GB010 Airport Lighting
EXS Existence Category
  (-32768) Null
HGT Height Above Surface Level (meters)
  (-32768) Null
LFA Light Function Aeronautical
  0 Unknown
  (10) Rotating Beacon
  26 Strobe
  72 Identification Beacon
ZV2 Highest Z-value (meters)
  (-32768) Null

GB220 -- Air Obstruction

GB220 Air Obstruction
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
HGT Height Above Surface Level (meters)
  (-32768) Null
LFA Light Function Aeronautical
  (-32768) Null
ZV2 Highest Z-value (meters)
  (-32768) Null


NavaidsP -- Navigation Aids

NavaidsP -- Navigation Aids

GA035 -- Navaids

GA035 Navaids
ATN Aids to Navigation
  (0) Unknown
  3 Lit
  4 Unlit
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

GA048 -- ILS Component

GA048 ILS Component
ATN Aids to Navigation
  (-32768) Null
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

GA055 -- Waypoint

GA055 Waypoint
ATN Aids to Navigation
  (-32768) Null
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


RailrdP -- Railroad Points

RailrdP -- Railroad Points

AN050 -- Railroad Siding/Railroad Spur

AN050 Railroad Siding/Railroad Spur
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  8 Dismantled
  28 Operational
LEN_/LEN Length/Diameter
  (-32768) Null
RRA Railroad Power Source
  (0) Unknown
  1 Electrified Track
  3 Overhead Electrified
  4 Non-Electrified
RRC Railroad Category
  (0) Unknown
  2 Car-Line
  3 Monorail
  8 Logging
  13 Marine Railroad
  14 Tramway
  15 Inclined Railroad
  16 Main Line
  21 Railroad in Road
  999 Other
RSA Railroad Siding Attribute
  (0) Unknown
  1 Spur
  2 Siding
  3 Passing

AN075 -- Railroad Turntable

AN075 Railroad Turntable
EXS Existence Category
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
RRA Railroad Power Source
  (-32768) Null
RRC Railroad Category
  (-32768) Null
RSA Railroad Siding Attribute
  (-32768) Null


RampP -- Ramp (Maritime)

RampP -- Ramp (Maritime)

BB220 Ramp (Maritime)
LEN_/LEN Length/Diameter
  (-32768) Null
VRR Vertical Reference Category
  (0) Unknown
  1 Above Surface/Does not cover (At High Water)
WID Width (meters)
  (-32768) Null


RestP -- Vehicle Stopping Area/Rest Area

RestP -- Vehicle Stopping Area/Rest Area

AQ135 Vehicle Stopping Area/Rest Area
No attributes except metadata


RoadP -- Road Points

RoadP -- Road Points

AH070 -- Check Point

AH070 Check Point
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  40 Subway
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AP032 -- Road Ramp

AP032 Road Ramp
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null

AP040 -- Gate

AP040 Gate
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  40 Subway
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AP041 -- Barrier

AP041 Barrier
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  40 Subway
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AQ058 -- Constriction/Expansion Point

AQ058 Constriction/Expansion Point
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null

AQ068 -- Drop Gate

AQ068 Drop Gate
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (0) Unknown
  1 Both Road and Railroad
  3 Railroad
  4 Road
  17 Pedestrian
  40 Subway
  999 Other
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown

AQ118 -- Sharp Curve Point

AQ118 Sharp Curve Point
PCI Point of Change Identifier
  (-32768) Null
TUC Transportation Use Category
  (-32768) Null
WD1 Minimum Traveled Way Width (decimeters)
  (-32768) Null


RryardP -- Railroad Yard/Marshalling Yard

RryardP -- Railroad Yard/Marshalling Yard

AN060 Railroad Yard/Marshalling Yard
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  28 Operational


RunwayP -- Runway Points

RunwayP -- Runway Points

GB054 -- Runway Graduated Point

GB054 Runway Graduated Point
AOO Angle of Orientation (degrees)
  (999) Unknown
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  0 Unknown
  6 Natural
  (7) Permanent
  8 Temporary
ZV3 Airfield/Aerodrome Elevation (meters)
  (29999) Unknown

GB055 -- Runway

GB055 Runway
AOO Angle of Orientation (degrees)
  (999) Unknown
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  0 Unknown
  6 Natural
  (7) Permanent
  8 Temporary
ZV3 Airfield/Aerodrome Elevation (meters)
  (29999) Unknown

GB056 -- Runway End Point

GB056 Runway End Point
AOO Angle of Orientation (degrees)
  (999) Unknown
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  7 Destroyed
  (28) Operational
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (-32768) Null
ZV3 Airfield/Aerodrome Elevation (meters)
  (29999) Unknown

GB061 -- Runway High Point

GB061 Runway High Point
AOO Angle of Orientation (degrees)
  (-32768) Null
EXS Existence Category
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (-32768) Null
ZV3 Airfield/Aerodrome Elevation (meters)
  (29999) Unknown

GB062 -- Runway Low Point

GB062 Runway Low Point
AOO Angle of Orientation (degrees)
  (-32768) Null
EXS Existence Category
  (-32768) Null
LEN_/LEN Length/Diameter
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
RST Road/Runway Surface Type
  (-32768) Null
ZV3 Airfield/Aerodrome Elevation (meters)
  (29999) Unknown


ShedP -- Snow/Rock Shed

ShedP -- Snow/Rock Shed

AL210 Snow/Rock Shed
LEN_/LEN Length/Diameter
  (0) MinValue
  74 MaxValue
USE_/USE Usage
  0 Unknown
  (115) Snow Shed
  116 Rock Shed


TrafficlightP -- Traffic Light

TrafficlightP -- Traffic Light

AQ160 Traffic Light
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
TXT Text Attribute
  (UNK) Unknown


TransP -- Bridge Superstructure/Route Marker

TransP -- Bridge Superstructure/Route Marker

AQ050 -- Bridge Superstructure

AQ050 Bridge Superstructure
EXS Existence Category
  (0) Unknown
  1 Definite
  2 Doubtful
  3 Reported
  5 Under Construction
  7 Destroyed
  28 Operational
OHB Overall Height of Bridge (meters)
  (0) Unknown
RTN Route Name
  (N/A) Null
USE_/USE Usage
  (-32768) Null
ZV2 Highest Z-value (meters)
  (29999) Unknown

AQ119 -- Route Marker

AQ119 Route Marker
EXS Existence Category
  (-32768) Null
OHB Overall Height of Bridge (meters)
  (-32768) Null
RTN Route Name
  (UNK) Unknown
USE_/USE Usage
  (4) National
  5 State
  23 International
ZV2 Highest Z-value (meters)
  (-32768) Null


TunnelP -- Tunnel

TunnelP -- Tunnel

AQ130 Tunnel
ACC Accuracy Category
  (0) Unknown
  1 Accurate
  2 Approximate
AOO Angle of Orientation (degrees)
  (0) Unknown
EXS Existence Category
  0 Unknown
  5 Under Construction
  (28) Operational
LEN_/LEN Length/Diameter
  (0) MinValue
  74 MaxValue
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
OHC Overhead Clearance Category
  (0) Unknown
TRA Traversability
  0 Unknown
  (1) Traversable
  2 Non-Traversable
TUC Transportation Use Category
  0 Unknown
  1 Both Road and Railroad
  3 Railroad
  (4) Road
  38 Canal
  41 Aqueduct
WD1 Minimum Traveled Way Width (decimeters)
  (0) Unknown


PowerA -- Power Plant

PowerA -- Power Plant

AD010 Power Plant
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
HGT Height Above Surface Level (meters)
  (29999) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PPC Power Plant Category
  (0) Unknown
  1 Hydro-electric
  2 Nuclear
  3 Solar
  4 Thermal
  6 Tidal
  7 Internal Combustion


PumpingA -- Pumping Station

PumpingA -- Pumping Station

AQ116 Pumping Station
PRO Product Category
  (0) Unknown
  38 Gas
  67 Oil
  116 Water
  999 Other
  1004 Wastewater
WID Width (meters)
  (-32768) Null
TXT Text Attribute
  (N/A) Null


SubstatA -- Substation/Transformer Yard

SubstatA -- Substation/Transformer Yard

AD030 Substation/Transformer Yard
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
HGT Height Above Surface Level (meters)
  (29999) Unknown
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null


PipeL -- Pipeline/Pipe

PipeL -- Pipeline/Pipe

AQ113 Pipeline/Pipe
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
  999 Other
LOC Location Category
  0 Unknown
  4 Below Water Surface
  (8) On Ground Surface
  25 Suspended or Elevated Above Ground or Water Surface
  40 Underground
PRO Product Category
  (0) Unknown
  13 Chemical
  38 Gas
  39 Gasoline
  67 Oil
  95 Sewage
  116 Water
  133 Telecommunications
  999 Other


PowerL -- Power Transmission Line

PowerL -- Power Transmission Line

AT030 Power Transmission Line
ACC Accuracy Category
  0 Unknown
  (1) Accurate
  2 Approximate
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
  999 Other
KVA Kilovolt Capacity Attribute
  (0) Unknown
NPL Number of Parallel Lines
  (0) Unknown


TeleL -- Telephone/Telegraph Line

TeleL -- Telephone/Telegraph Line

AT060 Telephone/Telegraph Line
EXS Existence Category
  (0) Unknown
  5 Under Construction
  6 Abandoned/Disused
  30 Not Isolated
  31 Isolated
NPL Number of Parallel Lines
  (0) Unknown
USE_/USE Usage
  (0) Unknown
  51 Telegraph
  52 Telephone


FirehydrantP -- Fire Hydrant

FirehydrantP -- Fire Hydrant

AL017 Fire Hydrant
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
  999 Other
TXT Text Attribute
  (UNK) Unknown


LightStandardP -- Light Standard

LightStandardP -- Light Standard

AL110 Light Standard
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
HGT Height Above Surface Level (meters)
  (29999) Unknown
MCC Material Composition Category
  (0) Unknown
  2 Aluminum
  64 Metal
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
SSC Structure Shape Category
  (0) Unknown
  52 A Frame
  53 H Frame
  54 I Frame
  56 Y Frame
  60 Mast
  999 Other
USE_/USE Usage
  (0) Unknown
  51 Telegraph
  52 Telephone
ZV2 Highest Z-value (meters)
  (29999) Unknown


PowerP -- Solar Panels

PowerP -- Solar Panels

AD020 Solar Panels
LEN_/LEN Length/Diameter
  (-32768) Null


PumpingP -- Pumping Station

PumpingP -- Pumping Station

AQ116 Pumping Station
LEN_/LEN Length/Diameter
  (-32768) Null
PRO Product Category
  (0) Unknown
  38 Gas
  67 Oil
  116 Water
  999 Other
  1004 Wastewater
WID Width (meters)
  (-32768) Null


SubstatP -- Substation/Transformer Yard

SubstatP -- Substation/Transformer Yard

AD030 Substation/Transformer Yard
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
HGT Height Above Surface Level (meters)
  (29999) Unknown
MCC Material Composition Category
  (-32768) Null
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (-32768) Null


UtilP -- Utility Pylons

UtilP -- Utility Pylons

AT040 -- Power Transmission Pylon

AT040 Power Transmission Pylon
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
HGT Height Above Surface Level (meters)
  (29999) Unknown
MCC Material Composition Category
  (0) Unknown
  2 Aluminum
  64 Metal
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (-32768) Null

AT070 -- Telephone/Telegraph Pylon

AT070 Telephone/Telegraph Pylon
EXS Existence Category
  0 Unknown
  5 Under Construction
  6 Abandoned/Disused
  (28) Operational
HGT Height Above Surface Level (meters)
  (29999) Unknown
MCC Material Composition Category
  (0) Unknown
  2 Aluminum
  64 Metal
  107 Steel
  117 Wood
  999 Other
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
USE_/USE Usage
  (0) Unknown
  51 Telegraph
  52 Telephone


CropA -- Rice Field/Cropland

CropA -- Rice Field/Cropland

BH135 -- Rice Field

BH135 Rice Field
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
FTC Farming Type Category
  (0) Unknown
  3 Terraced
  999 Other
VEG Vegetation Characteristics
  (-32768) Null

EA010 -- Cropland

EA010 Cropland
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
FTC Farming Type Category
  (0) Unknown
  1 Shifting cultivation
  3 Terraced
  999 Other
VEG Vegetation Characteristics
  (0) Unknown
  1 Dry Crops
  999 Other


FirebrkA -- Cleared Way/Cut Line/Firebreak

FirebrkA -- Cleared Way/Cut Line/Firebreak

EC040 Cleared Way/Cut Line/Firebreak
No attributes except metadata


GrassA -- Grassland Areas

GrassA -- Grassland Areas

BH077 -- Hummock

BH077 Hummock
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
DMB Density Measure (% of Brush/Undergrowth Cover)
  (-32768) Null
MAS Maintenance Status
  (-32768) Null
VEG Vegetation Characteristics
  (-32768) Null

EB010 -- Grassland

EB010 Grassland
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
DMB Density Measure (% of Brush/Undergrowth Cover)
  (-32768) Null
MAS Maintenance Status
  (-32768) Null
VEG Vegetation Characteristics
  (-32768) Null

EC010 -- Bamboo/Cane

EC010 Bamboo/Cane
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
DMB Density Measure (% of Brush/Undergrowth Cover)
  (-32768) Null
MAS Maintenance Status
  (-32768) Null
VEG Vegetation Characteristics
  (-32768) Null

EB020 -- Scrub/Brush

EB020 Scrub/Brush
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
DMB Density Measure (% of Brush/Undergrowth Cover)
  (-32768) Null
MAS Maintenance Status
  (-32768) Null
VEG Vegetation Characteristics
  (-32768) Null


OasisA -- Oasis

OasisA -- Oasis

EC020 Oasis
No attributes except metadata


OrchardA -- Nursery/Orchard/Plantation/Vineyards

OrchardA -- Nursery/Orchard/Plantation/Vineyards

EA030 -- Nursery

EA030 Nursery
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
PRO Product Category
  (-32768) Null

EA040 -- Orchard/Plantation

EA040 Orchard/Plantation
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
PRO Product Category
  (0) Unknown
  85 Rubber
  120 Bananas
  121 Cotton
  122 Bamboo
  123 Coffee
  124 Common fruit and/or nut
  125 Palms
  126 Palmetto
  999 Other

EA050 -- Vineyard

EA050 Vineyard
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
PRO Product Category
  (-32768) Null


SwampA -- Bog/Marsh/Swamp

SwampA -- Bog/Marsh/Swamp

BH015 -- Bog

BH015 Bog
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
VEG Vegetation Characteristics
  (0) Unknown
  6 Cranberry
  7 Peat
  999 Other

BH095 -- Marsh/Swamp

BH095 Marsh/Swamp
ARE_/ARE Area
  (0) Unknown
ARH Area Coverage Attribute (hectares)
  (0) Unknown
VEG Vegetation Characteristics
  (0) Unknown
  19 Mangrove
  24 Deciduous
  25 Evergreen
  50 Mixed Trees


TreesA -- Trees

TreesA -- Trees

EC030 Trees
BUD Brush/Undergrowth Density Category
  (0) Unknown
  2 Sparse (>5% to <=15%)
  4 Dense (>50%)
DMT Density Measure (% of Tree/Canopy Cover)
  (0) Unknown
EXS Existence Category
  (0) Unknown
  30 Not Isolated
  31 Isolated
NAM Name
  (UNK) Unknown
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null
PHT Predominant Height (meters)
  (29999) Unknown
PRO Product Category
  (-32768) -32768
SRD Surface Roughness Description
  (0) Unknown
  1 No Surface roughness effect
  2 Area of high landslide potential
  11 Surface of numerous cobbles and boulders
  12 Areas of stoney terrain
  13 Stony soil with surface rock
  14 Stony soil with scattered boulders
  15 Stony soil with numerous boulders
  16 Numerous boulders
  17 Numerous rock outcrops
  18 Area of scattered boulders
  19 Talus slope
  20 Boulder Field
  31 Highly Fractured surface rock
  32 Weathered lava flows
  33 Unweathered lava flows
  34 Stony soil with numerous rock outcrops
  35 Irregular surface with deep fractures of foliation
  36 Rugged terrain with numerous rock outcrops
  37 Rugged bedrock surface
  38 Sand dunes
  39 Sand dunes / low
  40 Sand dunes / high
  41 Active sand dunes
  42 Stabilized Sand dunes
  43 Highly distorted area sharp rocky ridges
  51 Stony soil cut by numerous gullies
  52 Moderately dissected terrain
  53 Moderately dissected terrian with scattered rock outcrops
  54 Dissected Floodplain
  55 Highly dissected terrain
  56 Area with deep erosional gullies
  57 Steep rugged dissected terrain with narrow gullies
  58 Karst areas of nemerous sinkholes solution valleys
  59 Karst area of numerous sinkholes
  60 Karst hummocky terrain covered with large conical hills
  61 Karst hummocky terrain covered with low broad-based mounds
  62 Arroyo wadi wash
  63 Playa Dry lake
  64 Area of numerous meander scars and or oxbow lakes
  65 Solifluction lobes and frost scars
  66 Hummocky ground areas of frost heaving
  67 Area of frost polygons
  68 Area containing sebkhas
  69 Area of numerous small lakes and ponds
  70 Area of numerous crevasses
  81 Area of numerous terraces
  82 Quarries
  83 Strip Mines
  84 Quarry / Gravel Pit
  85 Quarry / Sand pit
  86 Mine tailings / waste piles
  87 Salt Evaporators
  88 Area of numerous dikes
  89 Area of numerous diked fields
  90 Area of numerous fences
  91 Area of numerous stone walls
  92 Area of numerous man-made canals drains ditches
  93 Area of numerous terraced fileds
  94 Parallel earthen mounds (row crops)
  95 Area of numerous hedgerows
TSC Tree Spacing Category
  (0) Unknown
VEG Vegetation Characteristics
  (0) Unknown
  11 Casuarina
  12 Coniferous
  16 Nipa Palm
  17 Palm
  18 Filao
  24 Deciduous
  25 Evergreen
  29 Eucalyptus
  38 Cypress
  50 Mixed Trees
  52 Forest clearing
  55 With trees
  56 Without trees
  999 Other


TundraA -- Tundra

TundraA -- Tundra

BJ110 Tundra
No attributes except metadata


VegA -- Barren Ground/Hops

VegA -- Barren Ground/Hops

DA020 -- Barren Ground

DA020 Barren Ground
ARE_/ARE Area
  (-32768) Null
ARH Area Coverage Attribute (hectares)
  (-32768) Null
MCC Material Composition Category
  (-32768) Null
NAM Name
  (N/A) Null
NFI Named Feature Identifier
  (-32768) Null
NFN Name Identifier
  (-32768) Null

EA055 -- Hops

EA055 Hops
No attributes except metadata


FirebrkL -- Cleared Way/Cut Line/Firebreak

FirebrkL -- Cleared Way/Cut Line/Firebreak

EC040 Cleared Way/Cut Line/Firebreak
WID Width (meters)
  (-32768) Null


HedgeL -- Hedgerow

HedgeL -- Hedgerow

EA020 Hedgerow
No attributes except metadata


TreesL -- Tree Rows

TreesL -- Tree Rows

EC030 Tree Rows
PHT Predominant Height (meters)
  (29999) Unknown
SBC Shelter Belt Condition
  (0) Unknown
  1 Functions as a Shelter Belt
  2 Does Not Function as a Shelter Belt


OasisP -- Oasis

OasisP -- Oasis

EC020 Oasis
ARA Area Coverage Attribute
  (0) Unknown
VEG Vegetation Characteristics
  (0) Unknown
  17 Palm


TreesP -- Trees

TreesP -- Trees

EC030 Trees
EXS Existence Category
  0 Unknown
  (31) Isolated